[BACK]Return to installboot.8 CVS log [TXT][DIR] Up to [local] / sys / arch / sparc / stand / installboot

Annotation of sys/arch/sparc/stand/installboot/installboot.8, Revision 1.1

1.1     ! nbrk        1: .\"    $OpenBSD: installboot.8,v 1.9 2007/05/31 19:20:05 jmc Exp $
        !             2: .\"    $NetBSD: installboot.8,v 1.1 1995/09/30 21:32:14 pk Exp $
        !             3: .\"
        !             4: .\" Copyright (c) 1995 Paul Kranenburg
        !             5: .\" All rights reserved.
        !             6: .\"
        !             7: .\" Redistribution and use in source and binary forms, with or without
        !             8: .\" modification, are permitted provided that the following conditions
        !             9: .\" are met:
        !            10: .\" 1. Redistributions of source code must retain the above copyright
        !            11: .\"    notice, this list of conditions and the following disclaimer.
        !            12: .\" 2. Redistributions in binary form must reproduce the above copyright
        !            13: .\"    notice, this list of conditions and the following disclaimer in the
        !            14: .\"    documentation and/or other materials provided with the distribution.
        !            15: .\" 3. All advertising materials mentioning features or use of this software
        !            16: .\"    must display the following acknowledgement:
        !            17: .\"      This product includes software developed by Paul Kranenburg.
        !            18: .\" 3. The name of the author may not be used to endorse or promote products
        !            19: .\"    derived from this software without specific prior written permission
        !            20: .\"
        !            21: .\" THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
        !            22: .\" IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
        !            23: .\" OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
        !            24: .\" IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
        !            25: .\" INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
        !            26: .\" NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
        !            27: .\" DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
        !            28: .\" THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
        !            29: .\" (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
        !            30: .\" THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
        !            31: .\"
        !            32: .Dd $Mdocdate: May 31 2007 $
        !            33: .Dt INSTALLBOOT 8 sparc
        !            34: .Os
        !            35: .Sh NAME
        !            36: .Nm installboot
        !            37: .Nd install a bootstrap on an FFS filesystem partition
        !            38: .Sh SYNOPSIS
        !            39: .Nm installboot
        !            40: .Op Fl nvh
        !            41: .Op Fl a Ar karch
        !            42: .Ar boot
        !            43: .Ar bootxx
        !            44: .Ar device
        !            45: .Sh DESCRIPTION
        !            46: .Nm installboot
        !            47: prepares an FFS filesystem partition for boot-strapping from the PROM.
        !            48: The sparc bootblocks are split into two parts: a small first-stage program that
        !            49: is written into the superblock area in a partition
        !            50: .Po
        !            51: and hence is limited in size to SBSIZE - DEV_BSIZE bytes
        !            52: .Pc ,
        !            53: and a second-stage program that resides in the filesystem proper.
        !            54: The first-stage program is loaded into memory by the PROM.
        !            55: After it receives control, it loads the second stage program from a set of
        !            56: filesystem block numbers that have been hard-coded into it by the
        !            57: .Nm installboot
        !            58: program.
        !            59: The second-stage boot program uses the device driver interface to
        !            60: the PROM and the stand-alone filesystem code in
        !            61: .Dq libsa.a
        !            62: to locate and load the kernel.
        !            63: The second-stage boot program and the prototype code for the
        !            64: first-stage bootprogram can be found in
        !            65: .Pa /usr/mdec/boot
        !            66: and
        !            67: .Pa /usr/mdec/bootxx
        !            68: respectively.
        !            69: The second-stage program commonly resides in the root directory as
        !            70: .Pa /boot .
        !            71: The utility
        !            72: .Pa /usr/mdec/binstall
        !            73: can be used to properly copy the second-stage bootprogram to its destination.
        !            74: This script takes care of post-processing that is required on
        !            75: .Pf non- Tn Openboot
        !            76: machines.
        !            77: .Pp
        !            78: The options are as follows:
        !            79: .Bl -tag -width flag
        !            80: .It Fl a Ar karch
        !            81: Set the machine architecture.
        !            82: The argument
        !            83: .Ar karch
        !            84: can be one of
        !            85: .Dq sun4 ,
        !            86: .Dq sun4c
        !            87: or
        !            88: .Dq sun4m .
        !            89: Sun 4c models with
        !            90: .Tn Openboot
        !            91: PROMs need the header to be present, while Sun 4 systems with the
        !            92: .Dq old monitor
        !            93: interface require the header to be stripped off.
        !            94: This is normally taken care of by
        !            95: .Nm installboot
        !            96: automatically, but it's useful when preparing a bootable filesystem for
        !            97: another system.
        !            98: .It Fl h
        !            99: Leave the
        !           100: .Xr a.out 5
        !           101: header on the installed
        !           102: .Ar bootxx
        !           103: program.
        !           104: This option has been superseded by the
        !           105: .Fl a Ar karch
        !           106: option.
        !           107: .It Fl n
        !           108: Do not actually write anything on the disk.
        !           109: .It Fl v
        !           110: Verbose mode.
        !           111: .El
        !           112: .Pp
        !           113: The arguments are:
        !           114: .Bl -tag -width bootxx
        !           115: .It Ar boot
        !           116: the name of the second-stage boot program in the file system
        !           117: where the first-stage boot program is to be installed.
        !           118: .It Ar bootxx
        !           119: the name of the prototype file for the first stage boot program.
        !           120: .It Ar device
        !           121: the name of the raw device in which the first-stage boot program
        !           122: is to be installed.
        !           123: This should correspond to the block device on which the file system containing
        !           124: .Ar boot
        !           125: is mounted.
        !           126: .El
        !           127: .Sh EXAMPLES
        !           128: The following command will install the first-stage bootblocks in the
        !           129: root filesystem
        !           130: .Pq assumed to be mounted on Dq sd0a
        !           131: using the file
        !           132: .Pa /boot
        !           133: as the second-level boot program:
        !           134: .Bd -literal -offset indent
        !           135: installboot /boot /usr/mdec/bootxx /dev/rsd0a
        !           136: .Ed
        !           137: .Sh SEE ALSO
        !           138: .Xr disklabel 8 ,
        !           139: .Xr init 8
        !           140: .Sh HISTORY
        !           141: The
        !           142: .Nm installboot
        !           143: first appeared in
        !           144: .Nx 1.1 .
        !           145: .Sh BUGS
        !           146: .Nm installboot
        !           147: requires simultaneous access to the mounted file system and
        !           148: the raw device, but that is not allowed with the kernel
        !           149: .Dv securelevel
        !           150: variable set to a value greater than zero
        !           151: .Pq the default ,
        !           152: so
        !           153: .Nm installboot
        !           154: only works in single-user mode
        !           155: .Pq or insecure mode - see Xr init 8 .

CVSweb