[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / x11 / py-quickly

File: [local] / ports / x11 / py-quickly / Makefile (download)

Revision 1.3, Thu Aug 22 20:32:42 2019 UTC (4 years, 8 months ago) by kirby
Branch: MAIN
CVS Tags: HEAD
Changes since 1.2: +2 -1 lines

switch to PERMIT_PACKAGE

# $OpenBSD: Makefile.template,v 1.68 2013/10/02 07:34:45 ajacoutot Exp $

COMMENT =		set of application templates

MODPY_EGG_VERSION = 	12.08.1
DISTNAME =		quickly-${MODPY_EGG_VERSION}

CATEGORIES =		x11

HOMEPAGE =		https://launchpad.net/quickly/

MAINTAINER =		Kirill Bychkov <kirby@openbsd.org>

# GPLv3
PERMIT_PACKAGE =	Yes

MASTER_SITES =		https://launchpad.net/quickly/12.10/${MODPY_EGG_VERSION}/+download/

MODULES =		devel/dconf \
			lang/python \
			textproc/intltool
#MODPY_SETUPTOOLS = 	Yes
BUILD_DEPENDS =		devel/py-distutils-extra
#RUN_DEPENDS =		???
#TEST_DEPENDS =		???

NO_BUILD =		Yes
NO_TEST =		Yes

post-install:
	find ${WRKINST} -name "*.py" \
		-exec ${MODPY_BIN} ${MODPY_LIBDIR}/compileall.py {} \;

.include <bsd.port.mk>