[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / x11 / bino

File: [local] / ports / x11 / bino / Attic / Makefile (download)

Revision 1.4, Wed Oct 26 19:17:24 2011 UTC (12 years, 8 months ago) by yason
Branch: MAIN
Changes since 1.3: +8 -7 lines

bump version. still broken

# $OpenBSD$
#BROKEN = 		depends on linux-compat

COMMENT =		stereoscopic 3D video player

DISTNAME =		bino-1.1.1

CATEGORIES =		x11

HOMEPAGE =		http://www.nongnu.org/bino/

#MAINTAINER =		???

# GPLv3
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

WANTLIB += GL GLEW QtGui QtOpenGL avcodec avformat avutil bz2
WANTLIB += c gsm m mp3lame ogg openal orc-0.4 pthread schroedinger-1.0
WANTLIB += sndio speex stdc++ swscale theora vorbis vorbisenc
WANTLIB += x264 z

MASTER_SITES =		${MASTER_SITE_SAVANNAH:=bino/}
EXTRACT_SUFX =		.tar.xz

MODULES =		x11/qt4
#BUILD_DEPENDS =	
#RUN_DEPENDS =		???
LIB_DEPENDS =		audio/openal \
			graphics/ffmpeg \
			graphics/glew \
			multimedia/libass
#REGRESS_DEPENDS =	???

#REGRESS_FLAGS =	???

USE_GMAKE =		Yes
#USE_LIBTOOL =		Yes
CONFIGURE_STYLE =	autoconf
CONFIGURE_ARGS +=	--disable-silent-rules --enable-debug \
			--without-equalizer \
			--without-liblircclient
CONFIGURE_ENV += 	CPPFLAGS="-I${X11BASE}/include" \
			CXXFLAGS="-DHAVE_VASPRINTF=1 -DHAVE_SYSCONF=1" \
			LDFLAGS="-L${X11BASE}/lib"

AUTOCONF_VERSION =	2.67

#REGRESS_IS_INTERACTIVE =	Yes

#NO_REGRESS =		Yes

#REGRESS_TARGET =	???

.include <bsd.port.mk>