[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / www / sams

Annotation of ports/www/sams/Makefile, Revision 1.1

1.1     ! yason       1: # $OpenBSD$
        !             2:
        !             3: COMMENT =              Squid Account Management System
        !             4:
        !             5: DISTNAME =             sams-1.0.4
        !             6:
        !             7: #SHARED_LIBS =         ???
        !             8:
        !             9: CATEGORIES =           www
        !            10:
        !            11: HOMEPAGE =             http://sams.perm.ru/
        !            12:
        !            13: #MAINTAINER =          ???
        !            14:
        !            15: # GPLv2
        !            16: PERMIT_PACKAGE_CDROM = Yes
        !            17: PERMIT_PACKAGE_FTP =   Yes
        !            18: PERMIT_DISTFILES_CDROM =Yes
        !            19: PERMIT_DISTFILES_FTP = Yes
        !            20:
        !            21: WANTLIB =              c
        !            22:
        !            23: MASTER_SITES =         http://sams.perm.ru/download/
        !            24: #MASTER_SITES0 =
        !            25: EXTRACT_SUFX =         .tar.bz2
        !            26:
        !            27: #MODULES =             ???
        !            28: #BUILD_DEPENDS =       ???
        !            29: #RUN_DEPENDS =         ???
        !            30: LIB_DEPENDS =          mysqlclient::databases/mysql,-main \
        !            31:                        pcre::devel/pcre
        !            32: #REGRESS_DEPENDS =     ???
        !            33:
        !            34: #MAKE_FLAGS =          ???
        !            35: #MAKE_ENV =            ???
        !            36: #FAKE_FLAGS =          ???
        !            37: #REGRESS_FLAGS =       ???
        !            38:
        !            39: #SEPARATE_BUILD =      concurrent  (build simultaneously on all arches)
        !            40: #SEPARATE_BUILD =      simple  (configure/build still recreates files in source)
        !            41: USE_GMAKE =            Yes
        !            42: USE_LIBTOOL =          Yes
        !            43: CONFIGURE_STYLE =      gnu
        !            44: CONFIGURE_ARGS +=      ${CONFIGURE_SHARED} \
        !            45:                        --prefix=${PREFIX} \
        !            46:                        --with-mysql-libpath=${LOCALBASE}/lib \
        !            47:                        --with-pcre-libpath=${LOCALBASE}/lib
        !            48: #CONFIGURE_ENV =       ???
        !            49:
        !            50: #REGRESS_IS_INTERACTIVE =      Yes
        !            51:
        !            52: #NO_REGRESS =          Yes
        !            53:
        !            54: #CFLAGS =              ???
        !            55: #LDFLAGS =             ???
        !            56: #MAKE_FILE =           ???
        !            57: #PKG_ARCH =            ???
        !            58:
        !            59: #INSTALL_TARGET =      ???
        !            60: #REGRESS_TARGET =      ???
        !            61:
        !            62: do-install:
        !            63: .for i in sams samsdaemon samsf samsredir
        !            64:        ${INSTALL_PROGRAM} ${WRKSRC}/$i ${PREFIX}/bin/$i
        !            65: .endfor
        !            66:        ${INSTALL_DATA_DIR} ${PREFIX}/share/sams/
        !            67:        ${INSTALL_DATA} ${WRKSRC}/etc/sams.conf.default ${PREFIX}/share/sams/
        !            68:
        !            69: .include <bsd.port.mk>

CVSweb