[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / www / owncloud

Annotation of ports/www/owncloud/Makefile, Revision 1.6

1.1       kirby       1: # $OpenBSD: Makefile,v 1.137 2018/10/17 14:15:56 sthen Exp $
                      2:
                      3: COMMENT=               easy and universal access to shared and/or personal files
                      4:
1.6     ! kirby       5: V=                     10.10.0
1.1       kirby       6: DISTNAME=              owncloud-${V}
                      7: EXTRACT_SUFX=          .tar.bz2
                      8:
                      9: CATEGORIES=            www
                     10:
                     11: HOMEPAGE=              https://owncloud.org/
                     12:
                     13: MAINTAINER=            Antoine Jacoutot <ajacoutot@openbsd.org>
                     14:
                     15: # AGPLv3 (GNU Affero Public License)
                     16: # jQuery: MIT / GPLv3
                     17: # HTTP: 3 clause BSD
                     18: # MDB2: BSD-like
                     19: # User: AGPL
                     20: # XML/RPC: MIT / PHP
                     21: # Silk icons: Creative Commons Attribution
                     22: PERMIT_PACKAGE=        Yes
                     23:
1.5       kirby      24: MASTER_SITES=          https://download.owncloud.com/server/stable/
1.1       kirby      25:
                     26: MODULES=               lang/php
1.4       kirby      27: MODPHP_VERSION=                7.4
1.1       kirby      28:
                     29: NO_BUILD=              Yes
                     30: NO_TEST=               Yes
                     31: PKG_ARCH=              *
                     32:
                     33: WRKDIST=               ${WRKDIR}/owncloud
                     34:
                     35: PREFIX=                        ${VARBASE}/www
                     36: INSTDIR=               ${PREFIX}/owncloud
                     37: TINSTDIR=              ${TRUEPREFIX}/owncloud
                     38: VR=                    ${V:R}
                     39: SUBST_VARS=            INSTDIR TINSTDIR MODPHP_BIN VR
                     40:
                     41: RUN_DEPENDS=           lang/php/${MODPHP_VERSION},-gd \
                     42:                        lang/php/${MODPHP_VERSION},-zip \
                     43:                        ${MODPHP_PDO_DEPENDS}
                     44:
                     45: # http user authentication
                     46: RUN_DEPENDS +=         lang/php/${MODPHP_VERSION},-curl
                     47:
                     48: # apps extraction
                     49: RUN_DEPENDS +=         lang/php/${MODPHP_VERSION},-bz2
                     50:
                     51: # sorting of non-ASCII characters
                     52: RUN_DEPENDS +=         lang/php/${MODPHP_VERSION},-intl
                     53:
                     54: # distributed caching and Transactional File Locking
                     55: RUN_DEPENDS +=         databases/pecl-redis${MODPHP_FLAVOR}
                     56:
                     57: do-install:
                     58:        cp -Rp ${WRKSRC} ${INSTDIR}
                     59:        mv ${INSTDIR}/.htaccess ${INSTDIR}/.htaccess.dist
                     60:        find ${INSTDIR} -name '*.orig' -print0 | xargs -r0 rm
                     61:        chown -R ${BINOWN}:${BINGRP} ${INSTDIR}
                     62:
                     63:        chmod +x ${INSTDIR}/occ
                     64:        perl -pi -e '$$. == 1 && s|^.*env php.*$$|\#!${MODPHP_BIN}|;' \
                     65:                -e 'close ARGV if eof;' \
                     66:                ${INSTDIR}/occ
                     67:
                     68:        ${INSTALL_DATA_DIR} ${PREFIX}/conf/modules.sample
                     69:        ${SUBST_CMD} -m 0644 -c ${FILESDIR}/apache-httpd-owncloud.conf.dist.in \
                     70:                ${PREFIX}/conf/modules.sample/apache-httpd-owncloud.conf.dist
                     71:        ${INSTALL_DATA} ${FILESDIR}/config.php.dist.in \
                     72:                ${INSTDIR}/config/config.php.dist
                     73:
                     74: .include <bsd.port.mk>

CVSweb