[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / www / owncloud

Annotation of ports/www/owncloud/Makefile, Revision 1.1

1.1     ! kirby       1: # $OpenBSD: Makefile,v 1.137 2018/10/17 14:15:56 sthen Exp $
        !             2:
        !             3: COMMENT=               easy and universal access to shared and/or personal files
        !             4:
        !             5: V=                     10.5.0
        !             6: DISTNAME=              owncloud-${V}
        !             7: EXTRACT_SUFX=          .tar.bz2
        !             8:
        !             9: CATEGORIES=            www
        !            10:
        !            11: HOMEPAGE=              https://owncloud.org/
        !            12:
        !            13: MAINTAINER=            Antoine Jacoutot <ajacoutot@openbsd.org>
        !            14:
        !            15: # AGPLv3 (GNU Affero Public License)
        !            16: # jQuery: MIT / GPLv3
        !            17: # HTTP: 3 clause BSD
        !            18: # MDB2: BSD-like
        !            19: # User: AGPL
        !            20: # XML/RPC: MIT / PHP
        !            21: # Silk icons: Creative Commons Attribution
        !            22: PERMIT_PACKAGE=        Yes
        !            23:
        !            24: MASTER_SITES=          https://download.owncloud.org/community/
        !            25:
        !            26: MODULES=               lang/php
        !            27:
        !            28: NO_BUILD=              Yes
        !            29: NO_TEST=               Yes
        !            30: PKG_ARCH=              *
        !            31:
        !            32: WRKDIST=               ${WRKDIR}/owncloud
        !            33:
        !            34: PREFIX=                        ${VARBASE}/www
        !            35: INSTDIR=               ${PREFIX}/owncloud
        !            36: TINSTDIR=              ${TRUEPREFIX}/owncloud
        !            37: VR=                    ${V:R}
        !            38: SUBST_VARS=            INSTDIR TINSTDIR MODPHP_BIN VR
        !            39:
        !            40: RUN_DEPENDS=           lang/php/${MODPHP_VERSION},-gd \
        !            41:                        lang/php/${MODPHP_VERSION},-zip \
        !            42:                        ${MODPHP_PDO_DEPENDS}
        !            43:
        !            44: # http user authentication
        !            45: RUN_DEPENDS +=         lang/php/${MODPHP_VERSION},-curl
        !            46:
        !            47: # apps extraction
        !            48: RUN_DEPENDS +=         lang/php/${MODPHP_VERSION},-bz2
        !            49:
        !            50: # sorting of non-ASCII characters
        !            51: RUN_DEPENDS +=         lang/php/${MODPHP_VERSION},-intl
        !            52:
        !            53: # distributed caching and Transactional File Locking
        !            54: RUN_DEPENDS +=         databases/pecl-redis${MODPHP_FLAVOR}
        !            55:
        !            56: do-install:
        !            57:        cp -Rp ${WRKSRC} ${INSTDIR}
        !            58:        mv ${INSTDIR}/.htaccess ${INSTDIR}/.htaccess.dist
        !            59:        find ${INSTDIR} -name '*.orig' -print0 | xargs -r0 rm
        !            60:        chown -R ${BINOWN}:${BINGRP} ${INSTDIR}
        !            61:
        !            62:        chmod +x ${INSTDIR}/occ
        !            63:        perl -pi -e '$$. == 1 && s|^.*env php.*$$|\#!${MODPHP_BIN}|;' \
        !            64:                -e 'close ARGV if eof;' \
        !            65:                ${INSTDIR}/occ
        !            66:
        !            67:        ${INSTALL_DATA_DIR} ${PREFIX}/conf/modules.sample
        !            68:        ${SUBST_CMD} -m 0644 -c ${FILESDIR}/apache-httpd-owncloud.conf.dist.in \
        !            69:                ${PREFIX}/conf/modules.sample/apache-httpd-owncloud.conf.dist
        !            70:        ${INSTALL_DATA} ${FILESDIR}/config.php.dist.in \
        !            71:                ${INSTDIR}/config/config.php.dist
        !            72:
        !            73: .include <bsd.port.mk>

CVSweb