[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / www / goaccess

File: [local] / ports / www / goaccess / Attic / Makefile (download)

Revision 1.2, Wed Jul 10 16:14:03 2013 UTC (10 years, 10 months ago) by kirby
Branch: MAIN
Changes since 1.1: +6 -30 lines

 - cleanup
 - add GeoIP support
 - enable SEPARATE_BUILD

# $OpenBSD: Makefile.template,v 1.66 2013/06/04 22:58:11 sthen Exp $

COMMENT =		real-time web log analyzer and interactive viewer

DISTNAME =		goaccess-0.5

CATEGORIES =		www

HOMEPAGE =		http://goaccess.prosoftcorp.com/

#MAINTAINER =		???

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes

WANTLIB += 		GeoIP c glib-2.0 m menu ncurses

MASTER_SITES =		${MASTER_SITE_SOURCEFORGE:=goaccess/}

LIB_DEPENDS =		devel/glib2 \
			net/GeoIP

SEPARATE_BUILD =	Yes
CONFIGURE_STYLE =	gnu
CONFIGURE_ARGS +=	--enable-geoip
CONFIGURE_ENV =		CPPFLAGS="-I${LOCALBASE}/include" \
			LDFLAGS="-L${LOCALBASE}/lib"

.include <bsd.port.mk>