[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / www / goaccess

File: [local] / ports / www / goaccess / Attic / Makefile (download)

Revision 1.1, Wed Jul 10 15:51:03 2013 UTC (10 years, 10 months ago) by kirby
Branch: MAIN

Initial revision

# $OpenBSD: Makefile.template,v 1.66 2013/06/04 22:58:11 sthen Exp $

COMMENT =		real-time web log analyzer and interactive viewer

DISTNAME =		goaccess-0.5

CATEGORIES =		www

HOMEPAGE =		http://goaccess.prosoftcorp.com/

#MAINTAINER =		???

# Setting PERMIT_PACKAGE_CDROM=Yes defaults other PERMIT_* variables to Yes.
PERMIT_PACKAGE_CDROM =	Yes

WANTLIB += 		c glib-2.0 m menu ncurses

MASTER_SITES =		${MASTER_SITE_SOURCEFORGE:=goaccess/}

LIB_DEPENDS =		devel/glib2
#TEST_DEPENDS =		???

#MAKE_FLAGS =		???
#MAKE_ENV =		???
#FAKE_FLAGS =		???
#TEST_FLAGS =		???

#SEPARATE_BUILD =	Yes (build in a directory other than WRKSRC)
#SEPARATE_BUILD =	flavored (distinct flavors may share a common WRKSRC)
USE_GMAKE =		Yes
#USE_GROFF =		Yes
#USE_LIBTOOL=		gnu
CONFIGURE_STYLE =	gnu
#CONFIGURE_ARGS +=	${CONFIGURE_SHARED}
CONFIGURE_ENV =		CPPFLAGS="-I${LOCALBASE}/include" \
			LDFLAGS="-L${LOCALBASE}/lib"

#TEST_IS_INTERACTIVE =		Yes

#NO_TEST =		Yes

#CFLAGS =		???
#LDFLAGS =		???
#MAKE_FILE =		???
#PKG_ARCH =		??? (* for arch-independent packages)
#WRKDIST =		??? if other than ${WRKDIR}/${DISTNAME}
#WRKSRC =		??? if other than ${WRKDIST}
#WRKBUILD =		??? if other than ${WRKSRC}
#WRKCONF =		??? if other than ${WRKBUILD}

#TEST_TARGET =		???

.include <bsd.port.mk>