[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / www / awstats

File: [local] / ports / www / awstats / Attic / Makefile (download)

Revision 1.1.1.1 (vendor branch), Thu Feb 18 12:13:29 2010 UTC (14 years, 4 months ago) by yason
Branch: yason
CVS Tags: import
Changes since 1.1: +0 -0 lines

initial import

# $OpenBSD$

COMMENT =		generates web, streaming, ftp or mail server statistics

DISTNAME =		awstats-6.95

CATEGORIES =		www

HOMEPAGE =		http://awstats.sourceforge.net/

#MAINTAINER =		???

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

MASTER_SITES =		${MASTER_SITE_SOURCEFORGE:=awstats/}

#RUN_DEPENDS =		???

NO_BUILD =		Yes
NO_REGRESS =		Yes

PKG_ARCH =		*
PREFIX = 		/var/www
INSTDIR = 		${PREFIX}/htdocs/awstats
#SUBST_VARS = 		INSTDIR

do-configure:
	@perl -pi -e 's,__INSTDIR__,${INSTDIR},g' ${WRKDIST}/tools/httpd_conf
post-configure:
	@find ${WRKSRC} -name *.orig -exec rm {} \;
do-install:
	${INSTALL_DATA_DIR} ${INSTDIR}
	cd ${WRKDIST}; tar cf - . | tar xf - -C ${INSTDIR}
	${INSTALL_DATA} ${FILESDIR}/awstats.localhost.conf \
		${INSTDIR}/tools/awstats.localhost.conf
	@chown -R ${SHAREOWN}:${SHAREGRP} ${INSTDIR}

.include <bsd.port.mk>