[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / www / awstats

Annotation of ports/www/awstats/Makefile, Revision 1.1

1.1     ! yason       1: # $OpenBSD$
        !             2:
        !             3: COMMENT =              generates web, streaming, ftp or mail server statistics
        !             4:
        !             5: DISTNAME =             awstats-6.95
        !             6:
        !             7: CATEGORIES =           www
        !             8:
        !             9: HOMEPAGE =             http://awstats.sourceforge.net/
        !            10:
        !            11: #MAINTAINER =          ???
        !            12:
        !            13: # GPLv2
        !            14: PERMIT_PACKAGE_CDROM = Yes
        !            15: PERMIT_PACKAGE_FTP =   Yes
        !            16: PERMIT_DISTFILES_CDROM =Yes
        !            17: PERMIT_DISTFILES_FTP = Yes
        !            18:
        !            19: MASTER_SITES =         ${MASTER_SITE_SOURCEFORGE:=awstats/}
        !            20:
        !            21: #RUN_DEPENDS =         ???
        !            22:
        !            23: NO_BUILD =             Yes
        !            24: NO_REGRESS =           Yes
        !            25:
        !            26: PKG_ARCH =             *
        !            27: PREFIX =               /var/www
        !            28: INSTDIR =              ${PREFIX}/htdocs/awstats
        !            29: #SUBST_VARS =          INSTDIR
        !            30:
        !            31: do-configure:
        !            32:        @perl -pi -e 's,__INSTDIR__,${INSTDIR},g' ${WRKDIST}/tools/httpd_conf
        !            33: post-configure:
        !            34:        @find ${WRKSRC} -name *.orig -exec rm {} \;
        !            35: do-install:
        !            36:        ${INSTALL_DATA_DIR} ${INSTDIR}
        !            37:        cd ${WRKDIST}; tar cf - . | tar xf - -C ${INSTDIR}
        !            38:        ${INSTALL_DATA} ${FILESDIR}/awstats.localhost.conf \
        !            39:                ${INSTDIR}/tools/awstats.localhost.conf
        !            40:        @chown -R ${SHAREOWN}:${SHAREGRP} ${INSTDIR}
        !            41:
        !            42: .include <bsd.port.mk>

CVSweb