[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / textproc / sigil

File: [local] / ports / textproc / sigil / Attic / Makefile (download)

Revision 1.2, Wed Mar 14 09:19:07 2018 UTC (6 years, 2 months ago) by kirby
Branch: MAIN
Changes since 1.1: +16 -31 lines

cleanup

# $OpenBSD: Makefile.template,v 1.68 2013/10/02 07:34:45 ajacoutot Exp $

COMMENT =		epub editor

GH_ACCOUNT = 		Sigil-Ebook
GH_PROJECT = 		Sigil
GH_TAGNAME = 		0.9.3
DISTNAME =              sigil-${GH_TAGNAME}

CATEGORIES =		textproc

HOMEPAGE =		http://sigil-ebook.com/

MAINTAINER =		Kirill Bychkov <kirby@openbsd.org>

# GPLv3
PERMIT_PACKAGE_CDROM =	Yes

WANTLIB += Qt5Concurrent Qt5Core Qt5Gui Qt5Network Qt5PrintSupport
WANTLIB += Qt5Svg Qt5WebKit Qt5WebKitWidgets Qt5Widgets Qt5Xml
WANTLIB += Qt5XmlPatterns c hunspell-1.6 m pcre16 pthread z
WANTLIB += ${COMPILER_LIBCXX} ${MODPY_WANTLIB}

# c++11
COMPILER = 		base-clang ports-gcc
MODULES =		devel/cmake \
			lang/python \
			x11/qt5
#not sure it works only with python3
MODPY_VERSION=  ${MODPY_DEFAULT_VERSION_3}
#BUILD_DEPENDS =	???
RUN_DEPENDS =		textproc/py-lxml,python3 \
			devel/desktop-file-utils
LIB_DEPENDS =		devel/boost \
			textproc/hunspell \
			x11/qt5/qtsvg \
			x11/qt5/qtwebkit \
			x11/qt5/qtxmlpatterns

CONFIGURE_ARGS = 	-DUSE_SYSTEM_LIBS:BOOL=ON \
			-Wno-dev

NO_TEST =		Yes

#CFLAGS +=		-DUSE_FILE32API
#LDFLAGS =		???

.include <bsd.port.mk>