[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / textproc / goldendict

Annotation of ports/textproc/goldendict/Makefile, Revision 1.2

1.1       yason       1: # $OpenBSD$
                      2:
                      3: COMMENT =              feature-rich dictionary lookup program
                      4:
                      5: DISTNAME =             goldendict-0.9.0-src-x11
                      6: PKGNAME =              ${DISTNAME:S/-src-x11//}
                      7:
                      8: CATEGORIES =           textproc
                      9:
                     10: HOMEPAGE =             http://www.goldendict.org/
                     11:
                     12: #MAINTAINER =          ???
                     13:
                     14: # GPLv3
                     15: PERMIT_PACKAGE_CDROM = Yes
                     16: PERMIT_PACKAGE_FTP =   Yes
                     17: PERMIT_DISTFILES_CDROM =Yes
                     18: PERMIT_DISTFILES_FTP = Yes
                     19:
                     20: MASTER_SITES =         ${MASTER_SITE_BERLIOS:=goldendict/}
                     21: EXTRACT_SUFX =         .tar.bz2
                     22:
1.2     ! yason      23: WANTLIB += QtDBus QtGui QtNetwork QtWebKit QtXml QtXmlPatterns X11 Xtst c hunspell-1.2
        !            24: WANTLIB += iconv m ogg phonon pthread sqlite3 stdc++ vorbis vorbisfile z
1.1       yason      25:
                     26: MODULES =              x11/qt4
1.2     ! yason      27: LIB_DEPENDS =          ::textproc/hunspell \
        !            28:                        ${MODQT4_LIB_DEPENDS}
1.1       yason      29: RUN_DEPENDS =          ::devel/desktop-file-utils
                     30:
                     31: USE_X11 =              Yes
                     32:
                     33: WRKDIST =              ${WRKDIR}/${DISTNAME:S/-x11//}
                     34:
                     35: do-configure:
                     36:        cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${LOCALBASE}/bin/qmake4 \
                     37:                -unix INCLUDEPATH+=${X11BASE}/include \
                     38:                LIBS+=-L${LOCALBASE}/lib ${MAKE_FLAGS} goldendict.pro
                     39: do-install:
                     40:        ${INSTALL_PROGRAM} ${WRKSRC}/goldendict ${PREFIX}/bin/
                     41:        ${INSTALL_DATA_DIR} ${PREFIX}/share/icons/
                     42:        ${INSTALL_DATA_DIR} ${PREFIX}/share/applications/
                     43:        ${INSTALL_DATA} ${WRKSRC}/redist/icons/goldendict.png ${PREFIX}/share/icons/
                     44:        ${INSTALL_DATA} ${WRKSRC}/redist/goldendict.desktop ${PREFIX}/share/applications/
                     45:
                     46: .include <bsd.port.mk>

CVSweb