[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / sysutils / apcupsd

Annotation of ports/sysutils/apcupsd/Makefile, Revision 1.10

1.1       yason       1: # $OpenBSD$
                      2:
                      3: COMMENT-main =         daemon for controlling APC UPSes
                      4: COMMENT-cgi =          CGI scripts for web monitoring
                      5: COMMENT-x11 =          gapcmon - GUI for apcupsd
                      6:
1.9       yason       7: DISTNAME =             apcupsd-3.14.8
1.1       yason       8: PKGNAME-main =         ${DISTNAME}
                      9: PKGNAME-cgi =          ${DISTNAME:S/-/-cgi-/}
                     10: PKGNAME-x11 =          ${DISTNAME:S/-/-x11-/}
                     11:
                     12: CATEGORIES =           sysutils
                     13:
                     14: HOMEPAGE =             http://www.apcupsd.com
                     15:
1.4       yason      16: MAINTAINER =           Kirill Bychkov <yason@linklevel.net>
1.1       yason      17:
                     18: # GPLv2
                     19:
                     20: PERMIT_PACKAGE_CDROM = Yes
                     21: PERMIT_PACKAGE_FTP =   Yes
                     22: PERMIT_DISTFILES_CDROM = Yes
                     23: PERMIT_DISTFILES_FTP=  Yes
                     24:
                     25: WANTLIB-main =         c pthread
                     26:
1.3       yason      27: MASTER_SITES =         ${MASTER_SITE_SOURCEFORGE:=apcupsd/}
1.1       yason      28:
                     29: CONFIGURE_STYLE =      gnu old
                     30: USE_GMAKE =            Yes
                     31: MAKE_FLAGS =           VERBOSE=2
                     32:
                     33: WEB_ROOT =             /var/www
                     34:
                     35: CONFIGURE_ARGS =       --mandir=${LOCALBASE}/man \
                     36:                        --sbindir=${LOCALBASE}/sbin \
                     37:                        --sysconfdir=${SYSCONFDIR}/apcupsd \
                     38:                        --disable-install-distdir \
                     39:                        --with-cgi-bin=${WEB_ROOT}/cgi-bin/apcupsd \
                     40:                        --with-lock-dir=/var/run \
                     41:                        --with-nisip=127.0.0.1 \
                     42:                        --enable-usb
1.9       yason      43: CONFIGURE_ENV =        CPPFLAGS='-I${LOCALBASE}/include -I${X11BASE}/include' \
                     44:                        LDFLAGS='-L${LOCALBASE}/lib -L${X11BASE}/lib -pthread'
1.1       yason      45:
                     46: PSEUDO_FLAVORS =       no_x11
                     47: FLAVORS =              snmp
                     48: FLAVOR ?=
                     49:
                     50: MULTI_PACKAGES =       -main
                     51:
                     52: MULTI_PACKAGES +=      -cgi
                     53: PREFIX-cgi =           ${WEB_ROOT}
                     54: CONFIGURE_ARGS +=      --enable-cgi
                     55: WANTLIB-cgi =          c pthread
                     56: LIB_DEPENDS-cgi =      gd::graphics/gd
                     57:
                     58: .if !${FLAVOR:L:Mno_x11}
                     59: MULTI_PACKAGES +=      -x11
                     60: USE_X11 =              Yes
                     61: CONFIGURE_ARGS +=      --enable-gapcmon
                     62: WANTLIB-x11 =          ORBit-2 X11 Xau Xcomposite Xcursor Xdamage \
                     63:                        Xdmcp Xext Xfixes Xi Xinerama Xrandr Xrender \
1.2       yason      64:                        c dbus-1 expat fontconfig freetype gdk-x11-2.0 \
1.1       yason      65:                        gdk_pixbuf-2.0 gtk-x11-2.0 glitz iconv intl m \
                     66:                        pango-1.0 pangocairo-1.0 pangoft2-1.0 pixman-1 \
1.10    ! yason      67:                        png pthread pthread-stubs xcb xcb-render \
        !            68:                        xcb-render-util z
1.1       yason      69: LIB_DEPENDS-x11 =      glib-2.0.>=1400.0,gmodule-2.0.>=1400.0::devel/glib2 \
                     70:                        gobject-2.0.>=1400.0,gthread-2.0.>=1400::devel/glib2 \
1.2       yason      71:                        gio-2.0.>=1800::devel/glib2 \
1.1       yason      72:                        atk-1.0.>=2009::devel/atk \
                     73:                        cairo.>=7::graphics/cairo \
                     74:                        gconf-2.>=6::devel/gconf2
1.10    ! yason      75: RUN_DEPENDS-x11 =      ::devel/desktop-file-utils
1.1       yason      76: .endif
                     77:
                     78: .if ${FLAVOR:L:Msnmp}
                     79: CONFIGURE_ARGS +=      --enable-net-snmp
                     80: LIB_DEPENDS-main +=    netsnmp::net/net-snmp
                     81: WANTLIB-main +=        crypto
                     82: .endif
                     83:
                     84: post-install:
                     85: .for i in apcupsd apcupsd/status apcupsd/rpt apcupsd/etc
                     86:        ${INSTALL_DATA_DIR} ${PREFIX}/share/examples/$i
                     87: .endfor
                     88:        ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/apcupsd
                     89:        ${INSTALL_DATA} ${WRKSRC}/examples/status/* \
                     90:                ${PREFIX}/share/examples/apcupsd/status
                     91:        ${INSTALL_DATA} ${WRKSRC}/examples/rpt/* \
                     92:                ${PREFIX}/share/examples/apcupsd/rpt
                     93:        ${INSTALL_DATA} ${WRKSRC}/c ${PREFIX}/share/doc/apcupsd/COPYRIGHT
                     94:        ${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/doc/apcupsd
                     95:        ${INSTALL_DATA} ${WRKSRC}/DISCLAIMER ${PREFIX}/share/doc/apcupsd
                     96:        ${INSTALL_DATA} ${WRKSRC}/platforms/openbsd/README \
                     97:                ${PREFIX}/share/doc/apcupsd/README.openbsd
                     98:        ${INSTALL_DATA} ${WRKSRC}/src/cgi/README \
                     99:                ${WRKINST}/${WEB_ROOT}/cgi-bin/apcupsd/README.CGI
                    100:
                    101: .include <bsd.port.mk>

CVSweb