[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / security / sagan

File: [local] / ports / security / sagan / Makefile (download)

Revision 1.2, Sun Aug 28 17:13:13 2011 UTC (12 years, 8 months ago) by yason
Branch: MAIN
Changes since 1.1: +14 -28 lines

update to 0.2.0

# $OpenBSD$
USE_SYSTRACE=Yes
# check path to classifications.conf
# add rules file

COMMENT =		event log monitoring system

DISTNAME =		sagan-0.2.0

CATEGORIES =		security

HOMEPAGE =		http://sagan.quadrantsec.com/

MAINTAINER =		Kirill Bychkov <yason@linklevel.net>

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

WANTLIB =		c m pcap pcre pthread

MASTER_SITES =		${HOMEPAGE}/download/

#MODULES =		???
#BUILD_DEPENDS =	???
#RUN_DEPENDS =		???
LIB_DEPENDS =		devel/pcre

CONFIGURE_STYLE =	gnu
CONFIGURE_ARGS += 	--disable-esmtp \
			--disable-lognorm \
			--disable-postgresql \
			--disable-mysql \
			--disable-prelude \
			--disable-libdnet
CONFIGURE_ENV += 	CPPFLAGS=-I${LOCALBASE}/include \
			LDFLAGS=-L${LOCALBASE}/lib

NO_REGRESS =		Yes

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/sagan/
	$(INSTALL_DATA) ${WRKSRC}/etc/sagan.conf ${PREFIX}/share/sagan/sagan.conf"

.include <bsd.port.mk>