[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / security / sagan

File: [local] / ports / security / sagan / Makefile (download)

Revision 1.1.1.1 (vendor branch), Sat May 7 09:47:19 2011 UTC (13 years ago) by yason
Branch: yason
CVS Tags: import
Changes since 1.1: +0 -0 lines

initial import

# $OpenBSD$

COMMENT =		event log monitoring system

DISTNAME =		sagan-0.1.7

CATEGORIES =		security

HOMEPAGE =		http://sagan.softwink.com

#MAINTAINER =		???

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

WANTLIB =		c m pcre pthread

MASTER_SITES =		${HOMEPAGE}/download/

#MODULES =		???
#BUILD_DEPENDS =	???
#RUN_DEPENDS =		???
LIB_DEPENDS =		devel/pcre

CONFIGURE_STYLE =	gnu
CONFIGURE_ARGS +=	--disable-esmtp --disable-postgresql --disable-mysql --disable-prelude
CONFIGURE_ENV =		CPPFLAGS=-I${LOCALBASE}/include \
			LDFLAGS=-L${LOCALBASE}/lib

#FLAVORS =	1 2 3 a b
#FLAVOR ?=
# grab multiple choice value
#CHOICE = ${FLAVOR:L:Na:Nb}
# check that CHOICE is 1 OR 2 OR 3, or error out
#.if ${CHOICE} == "1"
# code for 1
#.elif ${CHOICE} == "2"
# code for 2
#.elif ${CHOICE} == "3"
# code for 3
#.else
#ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
#.endif
# check for switches
#.if ${FLAVOR:L:Ma}
# code for a
#.endif
#.if ${FLAVOR:L:Mb}
# code for b
#.endif

NO_REGRESS =		Yes

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/sagan/
	$(INSTALL_DATA) ${WRKSRC}/etc/sagan.conf ${PREFIX}/share/sagan/sagan.conf"

.include <bsd.port.mk>