[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / security / sagan

Annotation of ports/security/sagan/Makefile, Revision 1.1.1.1

1.1       yason       1: # $OpenBSD$
                      2:
                      3: COMMENT =              event log monitoring system
                      4:
                      5: DISTNAME =             sagan-0.1.7
                      6:
                      7: CATEGORIES =           security
                      8:
                      9: HOMEPAGE =             http://sagan.softwink.com
                     10:
                     11: #MAINTAINER =          ???
                     12:
                     13: # GPLv2
                     14: PERMIT_PACKAGE_CDROM = Yes
                     15: PERMIT_PACKAGE_FTP =   Yes
                     16: PERMIT_DISTFILES_CDROM =Yes
                     17: PERMIT_DISTFILES_FTP = Yes
                     18:
                     19: WANTLIB =              c m pcre pthread
                     20:
                     21: MASTER_SITES =         ${HOMEPAGE}/download/
                     22:
                     23: #MODULES =             ???
                     24: #BUILD_DEPENDS =       ???
                     25: #RUN_DEPENDS =         ???
                     26: LIB_DEPENDS =          devel/pcre
                     27:
                     28: CONFIGURE_STYLE =      gnu
                     29: CONFIGURE_ARGS +=      --disable-esmtp --disable-postgresql --disable-mysql --disable-prelude
                     30: CONFIGURE_ENV =                CPPFLAGS=-I${LOCALBASE}/include \
                     31:                        LDFLAGS=-L${LOCALBASE}/lib
                     32:
                     33: #FLAVORS =     1 2 3 a b
                     34: #FLAVOR ?=
                     35: # grab multiple choice value
                     36: #CHOICE = ${FLAVOR:L:Na:Nb}
                     37: # check that CHOICE is 1 OR 2 OR 3, or error out
                     38: #.if ${CHOICE} == "1"
                     39: # code for 1
                     40: #.elif ${CHOICE} == "2"
                     41: # code for 2
                     42: #.elif ${CHOICE} == "3"
                     43: # code for 3
                     44: #.else
                     45: #ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
                     46: #.endif
                     47: # check for switches
                     48: #.if ${FLAVOR:L:Ma}
                     49: # code for a
                     50: #.endif
                     51: #.if ${FLAVOR:L:Mb}
                     52: # code for b
                     53: #.endif
                     54:
                     55: NO_REGRESS =           Yes
                     56:
                     57: post-install:
                     58:        ${INSTALL_DATA_DIR} ${PREFIX}/share/sagan/
                     59:        $(INSTALL_DATA) ${WRKSRC}/etc/sagan.conf ${PREFIX}/share/sagan/sagan.conf"
                     60:
                     61: .include <bsd.port.mk>

CVSweb