[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / net / xmrig-proxy

File: [local] / ports / net / xmrig-proxy / Makefile (download)

Revision 1.2, Mon Sep 6 08:13:56 2021 UTC (2 years, 7 months ago) by kirby
Branch: MAIN
CVS Tags: HEAD
Changes since 1.1: +4 -1 lines

fix typo and set COMPILER

# $OpenBSD: Makefile.template,v 1.76 2017/02/25 16:04:20 danj Exp $

COMMENT =	Monero (XMR) Stratum protocol proxy

GH_ACCOUNT =	xmrig
GH_PROJECT =	xmrig-proxy
GH_TAGNAME =	v6.15.0

CATEGORIES =	net

MAINTAINER =	Kirill Bychkov <kirby@openbsd.org>

# GPLv3+
PERMIT_PACKAGE =	Yes

WANTLIB = ${COMPILER_LIBCXX} c crypto m ssl uv

# C++11
COMPILER = 	base-clang ports-gcc

MODULES =		devel/cmake

LIB_DEPENDS =		devel/libuv

CONFIGURE_ARGS =	-DWITH_HTTP=OFF

NO_TEST =		Yes

do-install:
	${INSTALL_PROGRAM} ${WRKBUILD}/xmrig-proxy \
		${PREFIX}/sbin/
	${INSTALL_DATA_DIR} ${PREFIX}/share/examples/xmrig-proxy/
	${INSTALL_DATA} ${WRKSRC}/src/config.json \
		${PREFIX}/share/examples/xmrig-proxy/
.include <bsd.port.mk>