[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / net / searpc

File: [local] / ports / net / searpc / Attic / Makefile (download)

Revision 1.1.1.1 (vendor branch), Mon Nov 11 19:58:43 2013 UTC (10 years, 6 months ago) by kirby
Branch: kirby
CVS Tags: kirby_20131111
Changes since 1.1: +0 -0 lines

import searpc draft

# $OpenBSD: Makefile.template,v 1.68 2013/10/02 07:34:45 ajacoutot Exp $
#ONLY_FOR_ARCHS =	???
#NOT_FOR_ARCHS =	???
#SHARED_ONLY =		???
#COMES_WITH =		???
#BROKEN =		reason

COMMENT =		simple RPC framework based on GObject system

V = 			2.0.6
DISTNAME = 		libsearpc-$V
DISTFILES =             ${DISTNAME}.zip{v$V.zip}

SHARED_LIBS += 		searpc-json-glib	0.0 # 1400.2
SHARED_LIBS += 		searpc			0.0 # 1.2

CATEGORIES =		net

#HOMEPAGE =		???	URL

#MAINTAINER =		???

# Setting PERMIT_PACKAGE_CDROM=Yes defaults other PERMIT_* variables to Yes.
PERMIT_PACKAGE_CDROM =	Yes

WANTLIB += ffi gio-2.0 glib-2.0 gmodule-2.0 gobject-2.0 pcre pthread
WANTLIB += z

MASTER_SITES =		https://github.com/haiwen/libsearpc/archive/

MODULES =		devel/gettext \
			lang/python
#BUILD_DEPENDS =	???
#RUN_DEPENDS =		???
LIB_DEPENDS =		devel/glib2
#TEST_DEPENDS =		???

#SEPARATE_BUILD =	Yes (build in a directory other than WRKSRC)
#SEPARATE_BUILD =	flavored (distinct flavors may share a common WRKSRC)
USE_GMAKE =		Yes
#USE_GROFF =		Yes
#USE_LIBTOOL=		gnu
CONFIGURE_STYLE =	automake
#CONFIGURE_ARGS +=	${CONFIGURE_SHARED}
#CONFIGURE_ENV =	???

AUTOCONF_VERSION =	2.63
AUTOMAKE_VERSION =	1.11

#FLAVORS =	1 2 3 a b
#FLAVOR ?=
# grab multiple choice value
#CHOICE = ${FLAVOR:Na:Nb}
# check that CHOICE is 1 OR 2 OR 3, or error out
#.if ${CHOICE} == "1"
# code for 1
#.elif ${CHOICE} == "2"
# code for 2
#.elif ${CHOICE} == "3"
# code for 3
#.else
#ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
#.endif
# check for switches
#.if ${FLAVOR:Ma}
# code for a
#.endif
#.if ${FLAVOR:Mb}
# code for b
#.endif

#CFLAGS =		???
#LDFLAGS =		???

#ALL_TARGET =		???
#INSTALL_TARGET =	???

pre-configure:
#	cd ${WRKSRC} && env AUTOCONF_VERSION=${AUTOCONF_VERSION} \
#		AUTOMAKE_VERSION=${AUTOMAKE_VERSION} libtoolize --force
#	cd ${WRKSRC} && env AUTOCONF_VERSION=${AUTOCONF_VERSION} \
#		AUTOMAKE_VERSION=${AUTOMAKE_VERSION} aclocal --force
#	cd ${WRKSRC} && env AUTOCONF_VERSION=${AUTOCONF_VERSION} \
#		AUTOMAKE_VERSION=${AUTOMAKE_VERSION} autoconf -f
#	cd ${WRKSRC} && env AUTOCONF_VERSION=${AUTOCONF_VERSION} \
#		AUTOMAKE_VERSION=${AUTOMAKE_VERSION} autoheader -f
#	cd ${WRKSRC} && env AUTOCONF_VERSION=${AUTOCONF_VERSION} \
#		AUTOMAKE_VERSION=${AUTOMAKE_VERSION} automake -a -c -f
	cd ${WRKSRC} && env AUTOCONF_VERSION=${AUTOCONF_VERSION} \
		AUTOMAKE_VERSION=${AUTOMAKE_VERSION} autoreconf --install


.include <bsd.port.mk>