[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / net / seafile / client

Annotation of ports/net/seafile/client/Makefile, Revision 1.1.1.1

1.1       kirby       1: # $OpenBSD: Makefile.template,v 1.68 2013/10/02 07:34:45 ajacoutot Exp $
                      2: #ONLY_FOR_ARCHS =      ???
                      3: #NOT_FOR_ARCHS =       ???
                      4: #SHARED_ONLY =         ???
                      5: #COMES_WITH =          ???
                      6: #BROKEN =              reason
                      7:
                      8: COMMENT =              seafile client
                      9: # COMMENT-foo =                ???     for multi packages
                     10:
                     11: DISTNAME =             seafile-client-${V}
                     12: #PKGNAME =             ???
                     13: #PKGNAME-foo =         ???     for multi packages
                     14:
                     15: #SHARED_LIBS =         ???
                     16:
                     17:
                     18: #WANTLIB =             ???
                     19:
                     20: #MODULES =             ???
                     21: #BUILD_DEPENDS =       ???
                     22: #RUN_DEPENDS =         ???
                     23: LIB_DEPENDS =          databases/libzdb \
                     24:                        devel/uuid,-main
                     25: #TEST_DEPENDS =                ???
                     26:
                     27: #MAKE_FLAGS =          ???
                     28: #MAKE_ENV =            ???
                     29: #FAKE_FLAGS =          ???
                     30: #TEST_FLAGS =          ???
                     31:
                     32: # build/configuration variables
                     33: #
                     34: #SEPARATE_BUILD =      Yes (build in a directory other than WRKSRC)
                     35: #SEPARATE_BUILD =      flavored (distinct flavors may share a common WRKSRC)
                     36: #USE_GMAKE =           Yes
                     37: #USE_GROFF =           Yes
                     38: #USE_LIBTOOL=          gnu
                     39: CONFIGURE_STYLE =      gnu
                     40: CONFIGURE_ARGS +=      --enable-python=no ${CONFIGURE_SHARED}
                     41: CONFIGURE_ENV =                CPPFLAGS=-I${LOCALBASE}/include \
                     42:                        LDFLAGS=-L${LOCALBASE}/lib
                     43:
                     44: # for gnu stuff
                     45: #AUTOCONF_VERSION =    ??? (defaults to 2.13)
                     46: #AUTOMAKE_VERSION =    ??? (defaults to 1.4)
                     47: # config.guess and others are copied here
                     48: #MODGNU_CONFIG_GUESS_DIRS = ??? (defaults to ${WRKSRC})
                     49:
                     50: # Is the build automagic or is it interactive
                     51: #
                     52: #IS_INTERACTIVE =              Yes
                     53: #TEST_IS_INTERACTIVE =         Yes
                     54:
                     55: # Assume you have one multiple choice flavor: 1 2 3 and switches a b.
                     56: # You would write
                     57: #
                     58: #FLAVORS =     1 2 3 a b
                     59: #FLAVOR ?=
                     60: # grab multiple choice value
                     61: #CHOICE = ${FLAVOR:Na:Nb}
                     62: # check that CHOICE is 1 OR 2 OR 3, or error out
                     63: #.if ${CHOICE} == "1"
                     64: # code for 1
                     65: #.elif ${CHOICE} == "2"
                     66: # code for 2
                     67: #.elif ${CHOICE} == "3"
                     68: # code for 3
                     69: #.else
                     70: #ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
                     71: #.endif
                     72: # check for switches
                     73: #.if ${FLAVOR:Ma}
                     74: # code for a
                     75: #.endif
                     76: #.if ${FLAVOR:Mb}
                     77: # code for b
                     78: #.endif
                     79:
                     80: # Things that we don't want to do for this port/package
                     81: # Generally, DON'T set anything to No if it's not needed.
                     82: # The time gained is not worth it.
                     83: #
                     84: #NO_BUILD =            Yes
                     85: #NO_TEST =             Yes
                     86:
                     87: # Overrides for default values
                     88: #
                     89: #CFLAGS =              ???
                     90: #LDFLAGS =             ???
                     91: #MAKE_FILE =           ???
                     92: #PKG_ARCH =            ??? (* for arch-independent packages)
                     93: WRKDIST =              ${WRKDIR}/seafile-${V}
                     94: #WRKSRC =              ??? if other than ${WRKDIST}
                     95: #WRKBUILD =            ??? if other than ${WRKSRC}
                     96: #WRKCONF =             ??? if other than ${WRKBUILD}
                     97:
                     98: #ALL_TARGET =          ???
                     99: #INSTALL_TARGET =      ???
                    100: #TEST_TARGET =         ???
                    101:
                    102: .include <bsd.port.mk>

CVSweb