[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / net / seafile / cli

Annotation of ports/net/seafile/cli/Makefile, Revision 1.1

1.1     ! kirby       1: # $OpenBSD: Makefile.template,v 1.68 2013/10/02 07:34:45 ajacoutot Exp $
        !             2: #ONLY_FOR_ARCHS =      ???
        !             3: #NOT_FOR_ARCHS =       ???
        !             4: #SHARED_ONLY =         ???
        !             5: #COMES_WITH =          ???
        !             6: #BROKEN =              reason
        !             7:
        !             8: COMMENT =              ???
        !             9: # COMMENT-foo =                ???     for multi packages
        !            10:
        !            11: #
        !            12: DISTNAME =             ???
        !            13: #PKGNAME =             ???
        !            14: #PKGNAME-foo =         ???     for multi packages
        !            15:
        !            16: #SHARED_LIBS =         ???
        !            17:
        !            18: # In case of GPL, version number must be appended (e.g. v2, v2+, v3).
        !            19: # Setting PERMIT_PACKAGE_CDROM=Yes defaults other PERMIT_* variables to Yes.
        !            20: #PERMIT_PACKAGE_CDROM =        Yes | Reason if No
        !            21: #PERMIT_PACKAGE_FTP =  Yes | Reason if No
        !            22: #PERMIT_DISTFILES_FTP =        Yes | Reason if No
        !            23:
        !            24: #WANTLIB =             ???
        !            25:
        !            26: #MODULES =             ???
        !            27: #BUILD_DEPENDS =       ???
        !            28: #RUN_DEPENDS =         ???
        !            29: #LIB_DEPENDS =         ???
        !            30: #TEST_DEPENDS =                ???
        !            31:
        !            32: #MAKE_FLAGS =          ???
        !            33: #MAKE_ENV =            ???
        !            34: #FAKE_FLAGS =          ???
        !            35: #TEST_FLAGS =          ???
        !            36:
        !            37: # build/configuration variables
        !            38: #
        !            39: #SEPARATE_BUILD =      Yes (build in a directory other than WRKSRC)
        !            40: #SEPARATE_BUILD =      flavored (distinct flavors may share a common WRKSRC)
        !            41: #USE_GMAKE =           Yes
        !            42: #USE_GROFF =           Yes
        !            43: # Programs that require GNU libtool to build instead of the OpenBSD one
        !            44: # should use this option.
        !            45: #USE_LIBTOOL=          gnu
        !            46: # Set CONFIGURE_STYLE to value corresponding to some standard configuration
        !            47: #        perl [modbuild]: perl's MakeMaker Makefile.PL (modbuild: perl's
        !            48: #        Module::Build Build.PL)
        !            49: #        gnu [autoconf] [old] [dest]: gnu style configure (old: no
        !            50: #        sysconfdir), (dest: add DESTDIR, does not handle it),
        !            51: #        (autoconf: needed by port, implies gnu)
        !            52: #      XXX: cygnus products do NOT use autoconf for making the main
        !            53: #              configure from configure.in
        !            54: #        imake [noman]: port uses imake for configuration.
        !            55: #        (noman: no man page installation)
        !            56: #        simple: port has its own configure script
        !            57: #CONFIGURE_STYLE =
        !            58: #CONFIGURE_SCRIPT =    ??? (if other than configure)
        !            59: #CONFIGURE_ARGS +=     ${CONFIGURE_SHARED}
        !            60: #CONFIGURE_ENV =       ???
        !            61:
        !            62: # for gnu stuff
        !            63: #AUTOCONF_VERSION =    ??? (defaults to 2.13)
        !            64: #AUTOMAKE_VERSION =    ??? (defaults to 1.4)
        !            65: # config.guess and others are copied here
        !            66: #MODGNU_CONFIG_GUESS_DIRS = ??? (defaults to ${WRKSRC})
        !            67:
        !            68: # Is the build automagic or is it interactive
        !            69: #
        !            70: #IS_INTERACTIVE =              Yes
        !            71: #TEST_IS_INTERACTIVE =         Yes
        !            72:
        !            73: # Assume you have one multiple choice flavor: 1 2 3 and switches a b.
        !            74: # You would write
        !            75: #
        !            76: #FLAVORS =     1 2 3 a b
        !            77: #FLAVOR ?=
        !            78: # grab multiple choice value
        !            79: #CHOICE = ${FLAVOR:Na:Nb}
        !            80: # check that CHOICE is 1 OR 2 OR 3, or error out
        !            81: #.if ${CHOICE} == "1"
        !            82: # code for 1
        !            83: #.elif ${CHOICE} == "2"
        !            84: # code for 2
        !            85: #.elif ${CHOICE} == "3"
        !            86: # code for 3
        !            87: #.else
        !            88: #ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
        !            89: #.endif
        !            90: # check for switches
        !            91: #.if ${FLAVOR:Ma}
        !            92: # code for a
        !            93: #.endif
        !            94: #.if ${FLAVOR:Mb}
        !            95: # code for b
        !            96: #.endif
        !            97:
        !            98: # Things that we don't want to do for this port/package
        !            99: # Generally, DON'T set anything to No if it's not needed.
        !           100: # The time gained is not worth it.
        !           101: #
        !           102: #NO_BUILD =            Yes
        !           103: #NO_TEST =             Yes
        !           104:
        !           105: # Overrides for default values
        !           106: #
        !           107: #CFLAGS =              ???
        !           108: #LDFLAGS =             ???
        !           109: #MAKE_FILE =           ???
        !           110: #PKG_ARCH =            ??? (* for arch-independent packages)
        !           111: #WRKDIST =             ??? if other than ${WRKDIR}/${DISTNAME}
        !           112: #WRKSRC =              ??? if other than ${WRKDIST}
        !           113: #WRKBUILD =            ??? if other than ${WRKSRC}
        !           114: #WRKCONF =             ??? if other than ${WRKBUILD}
        !           115:
        !           116: #ALL_TARGET =          ???
        !           117: #INSTALL_TARGET =      ???
        !           118: #TEST_TARGET =         ???
        !           119:
        !           120: .include <bsd.port.mk>

CVSweb