[BACK]Return to Makefile.inc CVS log [TXT][DIR] Up to [local] / ports / net / seafile

Annotation of ports/net/seafile/Makefile.inc, Revision 1.2

1.1       kirby       1: # $OpenBSD: Makefile.template,v 1.68 2013/10/02 07:34:45 ajacoutot Exp $
                      2: #ONLY_FOR_ARCHS =      ???
                      3: #NOT_FOR_ARCHS =       ???
                      4: #SHARED_ONLY =         ???
                      5: #COMES_WITH =          ???
                      6: #BROKEN =              reason
                      7:
1.2     ! kirby       8: V =                    2.0.8
        !             9: DISTNAME =             ${NAME}-${V}
1.1       kirby      10:
                     11: CATEGORIES =           net net/seafile
                     12:
                     13: HOMEPAGE =             http://www.seafile.com/
                     14:
                     15: MAINTAINER =           Kirill Bychkov <kirby@openbsd.org>
                     16:
                     17: # GPLv3
                     18: PERMIT_PACKAGE_CDROM = Yes
                     19:
1.2     ! kirby      20: MASTER_SITES =         https://github.com/haiwen/${NAME}/archive/
        !            21: DISTFILES =            ${DISTNAME}${EXTRACT_SUFX}{v$V${EXTRACT_SUFX}}
1.1       kirby      22:
                     23: #DIST_SUBDIR =         ???
                     24:
                     25: #MODULES =             ???
                     26: #BUILD_DEPENDS =       ???
                     27: #RUN_DEPENDS =         ???
                     28: #LIB_DEPENDS =         ???
                     29: #TEST_DEPENDS =                ???
                     30:
                     31: #MAKE_FLAGS =          ???
                     32: #MAKE_ENV =            ???
                     33: #FAKE_FLAGS =          ???
                     34: #TEST_FLAGS =          ???
                     35:
                     36: #SEPARATE_BUILD =      Yes (build in a directory other than WRKSRC)
                     37: #SEPARATE_BUILD =      flavored (distinct flavors may share a common WRKSRC)
                     38: #USE_GMAKE =           Yes
                     39: #USE_GROFF =           Yes
                     40: # Programs that require GNU libtool to build instead of the OpenBSD one
                     41: # should use this option.
                     42: #USE_LIBTOOL=          gnu
                     43: #CONFIGURE_STYLE =
                     44: #CONFIGURE_SCRIPT =    ??? (if other than configure)
                     45: #CONFIGURE_ARGS +=     ${CONFIGURE_SHARED}
                     46: #CONFIGURE_ENV =       ???
                     47:
                     48: # for gnu stuff
                     49: #AUTOCONF_VERSION =    ??? (defaults to 2.13)
                     50: #AUTOMAKE_VERSION =    ??? (defaults to 1.4)
                     51: # config.guess and others are copied here
                     52: #MODGNU_CONFIG_GUESS_DIRS = ??? (defaults to ${WRKSRC})
                     53:
                     54: # Is the build automagic or is it interactive
                     55: #
                     56: #IS_INTERACTIVE =              Yes
                     57: #TEST_IS_INTERACTIVE =         Yes
                     58:
                     59: # Assume you have one multiple choice flavor: 1 2 3 and switches a b.
                     60: # You would write
                     61: #
                     62: #FLAVORS =     1 2 3 a b
                     63: #FLAVOR ?=
                     64: # grab multiple choice value
                     65: #CHOICE = ${FLAVOR:Na:Nb}
                     66: # check that CHOICE is 1 OR 2 OR 3, or error out
                     67: #.if ${CHOICE} == "1"
                     68: # code for 1
                     69: #.elif ${CHOICE} == "2"
                     70: # code for 2
                     71: #.elif ${CHOICE} == "3"
                     72: # code for 3
                     73: #.else
                     74: #ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
                     75: #.endif
                     76: # check for switches
                     77: #.if ${FLAVOR:Ma}
                     78: # code for a
                     79: #.endif
                     80: #.if ${FLAVOR:Mb}
                     81: # code for b
                     82: #.endif
                     83:
                     84: # Things that we don't want to do for this port/package
                     85: # Generally, DON'T set anything to No if it's not needed.
                     86: # The time gained is not worth it.
                     87: #
                     88: #NO_BUILD =            Yes
                     89: #NO_TEST =             Yes
                     90:
                     91: # Overrides for default values
                     92: #
                     93: #CFLAGS =              ???
                     94: #LDFLAGS =             ???
                     95: #MAKE_FILE =           ???
                     96: #PKG_ARCH =            ??? (* for arch-independent packages)
                     97: #WRKDIST =             ??? if other than ${WRKDIR}/${DISTNAME}
                     98: #WRKSRC =              ??? if other than ${WRKDIST}
                     99: #WRKBUILD =            ??? if other than ${WRKSRC}
                    100: #WRKCONF =             ??? if other than ${WRKBUILD}
                    101:
                    102: #ALL_TARGET =          ???
                    103: #INSTALL_TARGET =      ???
                    104: #TEST_TARGET =         ???
                    105:
                    106: #.include <bsd.port.mk>

CVSweb