[BACK]Return to Makefile.inc CVS log [TXT][DIR] Up to [local] / ports / net / seafile

Annotation of ports/net/seafile/Makefile.inc, Revision 1.1.1.1

1.1       kirby       1: # $OpenBSD: Makefile.template,v 1.68 2013/10/02 07:34:45 ajacoutot Exp $
                      2: #ONLY_FOR_ARCHS =      ???
                      3: #NOT_FOR_ARCHS =       ???
                      4: #SHARED_ONLY =         ???
                      5: #COMES_WITH =          ???
                      6: #BROKEN =              reason
                      7:
                      8: V =                    2.0.6
                      9:
                     10: CATEGORIES =           net net/seafile
                     11:
                     12: HOMEPAGE =             http://www.seafile.com/
                     13:
                     14: MAINTAINER =           Kirill Bychkov <kirby@openbsd.org>
                     15:
                     16: # GPLv3
                     17: PERMIT_PACKAGE_CDROM = Yes
                     18:
                     19: MASTER_SITES =         https://seafile.googlecode.com/files/
                     20:
                     21: #DIST_SUBDIR =         ???
                     22:
                     23: #MODULES =             ???
                     24: #BUILD_DEPENDS =       ???
                     25: #RUN_DEPENDS =         ???
                     26: #LIB_DEPENDS =         ???
                     27: #TEST_DEPENDS =                ???
                     28:
                     29: #MAKE_FLAGS =          ???
                     30: #MAKE_ENV =            ???
                     31: #FAKE_FLAGS =          ???
                     32: #TEST_FLAGS =          ???
                     33:
                     34: # build/configuration variables
                     35: #
                     36: #SEPARATE_BUILD =      Yes (build in a directory other than WRKSRC)
                     37: #SEPARATE_BUILD =      flavored (distinct flavors may share a common WRKSRC)
                     38: #USE_GMAKE =           Yes
                     39: #USE_GROFF =           Yes
                     40: # Programs that require GNU libtool to build instead of the OpenBSD one
                     41: # should use this option.
                     42: #USE_LIBTOOL=          gnu
                     43: # Set CONFIGURE_STYLE to value corresponding to some standard configuration
                     44: #        perl [modbuild]: perl's MakeMaker Makefile.PL (modbuild: perl's
                     45: #        Module::Build Build.PL)
                     46: #        gnu [autoconf] [old] [dest]: gnu style configure (old: no
                     47: #        sysconfdir), (dest: add DESTDIR, does not handle it),
                     48: #        (autoconf: needed by port, implies gnu)
                     49: #      XXX: cygnus products do NOT use autoconf for making the main
                     50: #              configure from configure.in
                     51: #        imake [noman]: port uses imake for configuration.
                     52: #        (noman: no man page installation)
                     53: #        simple: port has its own configure script
                     54: #CONFIGURE_STYLE =
                     55: #CONFIGURE_SCRIPT =    ??? (if other than configure)
                     56: #CONFIGURE_ARGS +=     ${CONFIGURE_SHARED}
                     57: #CONFIGURE_ENV =       ???
                     58:
                     59: # for gnu stuff
                     60: #AUTOCONF_VERSION =    ??? (defaults to 2.13)
                     61: #AUTOMAKE_VERSION =    ??? (defaults to 1.4)
                     62: # config.guess and others are copied here
                     63: #MODGNU_CONFIG_GUESS_DIRS = ??? (defaults to ${WRKSRC})
                     64:
                     65: # Is the build automagic or is it interactive
                     66: #
                     67: #IS_INTERACTIVE =              Yes
                     68: #TEST_IS_INTERACTIVE =         Yes
                     69:
                     70: # Assume you have one multiple choice flavor: 1 2 3 and switches a b.
                     71: # You would write
                     72: #
                     73: #FLAVORS =     1 2 3 a b
                     74: #FLAVOR ?=
                     75: # grab multiple choice value
                     76: #CHOICE = ${FLAVOR:Na:Nb}
                     77: # check that CHOICE is 1 OR 2 OR 3, or error out
                     78: #.if ${CHOICE} == "1"
                     79: # code for 1
                     80: #.elif ${CHOICE} == "2"
                     81: # code for 2
                     82: #.elif ${CHOICE} == "3"
                     83: # code for 3
                     84: #.else
                     85: #ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
                     86: #.endif
                     87: # check for switches
                     88: #.if ${FLAVOR:Ma}
                     89: # code for a
                     90: #.endif
                     91: #.if ${FLAVOR:Mb}
                     92: # code for b
                     93: #.endif
                     94:
                     95: # Things that we don't want to do for this port/package
                     96: # Generally, DON'T set anything to No if it's not needed.
                     97: # The time gained is not worth it.
                     98: #
                     99: #NO_BUILD =            Yes
                    100: #NO_TEST =             Yes
                    101:
                    102: # Overrides for default values
                    103: #
                    104: #CFLAGS =              ???
                    105: #LDFLAGS =             ???
                    106: #MAKE_FILE =           ???
                    107: #PKG_ARCH =            ??? (* for arch-independent packages)
                    108: #WRKDIST =             ??? if other than ${WRKDIR}/${DISTNAME}
                    109: #WRKSRC =              ??? if other than ${WRKDIST}
                    110: #WRKBUILD =            ??? if other than ${WRKSRC}
                    111: #WRKCONF =             ??? if other than ${WRKBUILD}
                    112:
                    113: #ALL_TARGET =          ???
                    114: #INSTALL_TARGET =      ???
                    115: #TEST_TARGET =         ???
                    116:
                    117: #.include <bsd.port.mk>

CVSweb