[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / net / imspector

Annotation of ports/net/imspector/Makefile, Revision 1.1.1.1

1.1       yason       1: # $OpenBSD$
                      2: #ONLY_FOR_ARCHS =      ???
                      3: #NOT_FOR_ARCHS =       ???
                      4: #SHARED_ONLY =         ???
                      5: #COMES_WITH =          ???
                      6: #BROKEN =              reason
                      7:
                      8: COMMENT =              IM proxy with monitoring
                      9:
                     10: DISTNAME =             imspector-0.8
                     11:
                     12: #SHARED_LIBS =         ???
                     13:
                     14: CATEGORIES =           net
                     15:
                     16: HOMEPAGE =             http://www.imspector.org
                     17:
                     18: MAINTAINER =           Kirill Bychkov <yason@linklevel.net>
                     19:
                     20: # GPL v2
                     21: PERMIT_PACKAGE_CDROM = Yes
                     22: PERMIT_PACKAGE_FTP =   Yes
                     23: PERMIT_DISTFILES_CDROM =Yes
                     24: PERMIT_DISTFILES_FTP = Yes
                     25:
                     26: MASTER_SITES =         ${HOMEPAGE}/downloads/
                     27:
                     28: WANTLIB =              c m stdc++
                     29: LIB_DEPENDS =          iconv.>=6::converters/libiconv
                     30: #REGRESS_DEPENDS =     ???
                     31:
                     32: #MAKE_FLAGS =          ???
                     33: #MAKE_ENV =            ???
                     34: #FAKE_FLAGS =          ???
                     35: #REGRESS_FLAGS =       ???
                     36:
                     37: # build/configuration variables
                     38: #
                     39: #SEPARATE_BUILD =      concurrent  (build simultaneously on all arches)
                     40: #SEPARATE_BUILD =      simple  (configure/build still recreates files in source)
                     41: #USE_X11 =             Yes
                     42: #USE_GMAKE =           Yes
                     43: # Programs that uses libtool should use this option,
                     44: # unless there is a really good reason not to.
                     45: #USE_LIBTOOL =         Yes
                     46: # Set CONFIGURE_STYLE to value corresponding to some standard configuration
                     47: #        perl [modbuild]: perl's MakeMaker Makefile.PL (modbuild: perl's
                     48: #        Module::Build Build.PL)
                     49: #        gnu [autoconf] [old] [dest]: gnu style configure (old: no
                     50: #        sysconfdir), (dest: add DESTDIR, does not handle it),
                     51: #        (autoconf: needed by port, implies gnu)
                     52: #      XXX: cygnus products do NOT use autoconf for making the main
                     53: #              configure from configure.in
                     54: #        imake [noman]: port uses imake for configuration.
                     55: #        (noman: no man page installation)
                     56: #        simple: port has its own configure script
                     57: #CONFIGURE_STYLE =
                     58: #CONFIGURE_SCRIPT =    ??? (if other than configure)
                     59: #CONFIGURE_ARGS +=     ${CONFIGURE_SHARED}
                     60: #CONFIGURE_ENV +=      LIBS=-L${PREFIX}/lib -liconv \
                     61: #              CXXFLAGS=-I${PREFIX}/include
                     62:
                     63: # for gnu stuff
                     64: #AUTOCONF_VERSION =    ??? (defaults to 2.13)
                     65: #AUTOMAKE_VERSION =    ??? (defaults to 1.4)
                     66: #MODGNU_CONFIG_GUESS_DIRS = ??? (defaults to ${WRKSRC}
                     67:
                     68: # Is the build automagic or is it interactive
                     69: #
                     70: #IS_INTERACTIVE =              Yes
                     71: #REGRESS_IS_INTERACTIVE =      Yes
                     72:
                     73: # Assume you have one multiple choice flavor: 1 2 3 and switches a b.
                     74: # You would write
                     75: #
                     76: #FLAVORS =     1 2 3 a b
                     77: #FLAVOR ?=
                     78: # grab multiple choice value
                     79: #CHOICE = ${FLAVOR:L:Na:Nb}
                     80: # check that CHOICE is 1 OR 2 OR 3, or error out
                     81: #.if ${CHOICE} == "1"
                     82: # code for 1
                     83: #.elif ${CHOICE} == "2"
                     84: # code for 2
                     85: #.elif ${CHOICE} == "3"
                     86: # code for 3
                     87: #.else
                     88: #ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
                     89: #.endif
                     90: # check for switches
                     91: #.if ${FLAVOR:L:Ma}
                     92: # code for a
                     93: #.endif
                     94: #.if ${FLAVOR:L:Mb}
                     95: # code for b
                     96: #.endif
                     97:
                     98: # Things that we don't want to do for this port/package
                     99: # Generally, DON'T set anything to No if it's not needed.
                    100: # The time gained is not worth it.
                    101: #
                    102: #NO_BUILD =            Yes
                    103: #NO_REGRESS =          Yes
                    104:
                    105: # Overrides for default values
                    106: #
                    107: #CFLAGS =              ???
                    108: #LDFLAGS =             ???
                    109: #MAKE_FILE =           ???
                    110: #PKG_ARCH =            ???
                    111: #WRKDIST =             ??? if other than ${WRKDIR}/$DISTNAME
                    112: #WRKSRC =              ??? if other than ${WRKDIST}
                    113: #WRKBUILD =            ??? if other than ${WRKSRC}
                    114: #WRKCONF =             ??? if other than ${WRKBUILD}
                    115:
                    116: #ALL_TARGET =          ???
                    117: #INSTALL_TARGET =      ???
                    118: #REGRESS_TARGET =      ???
                    119:
                    120: .include <bsd.port.mk>

CVSweb