[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / net / c-icap

File: [local] / ports / net / c-icap / Attic / Makefile (download)

Revision 1.2, Sat Jan 3 00:25:55 2009 UTC (15 years, 5 months ago) by yason
Branch: MAIN
Changes since 1.1: +2 -5 lines

sysconfdir issue overcame, need correct otions for /var related stuff and improvements in perl_module

# $OpenBSD$

COMMENT =		implementation of an ICAP server

DISTNAME =		c_icap-060708rc1
PKGNAME =		c-icap-060708

# for libtool-based ports, have a look at WRKBUILD/shared_libs.log
SHARED_LIBS =		icapapi 0.1

CATEGORIES =		net www

HOMEPAGE =		http://c-icap.sourceforge.net/

MAINTAINER =		Kirill S. Bychkov <yason@linklevel.net>

#GPLv2
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

WANTLIB =		c pthread z

MASTER_SITES =		${MASTER_SITE_SOURCEFORGE:=c-icap/}

BUILD_DEPENDS =		::security/clamav
#RUN_DEPENDS =		???
#LIB_DEPENDS =		???

#MAKE_FLAGS =		???
#MAKE_ENV =		???
#FAKE_FLAGS =		???

#USE_LIBTOOL =		Yes
CONFIGURE_STYLE =	gnu old
CONFIGURE_ARGS =	--prefix=${PREFIX} \
			--sysconfdir=${SYSCONFDIR}/c-icap \
			${CONFIGURE_SHARED}
CONFIGURE_ENV += 	CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/examples/c-icap/
	${INSTALL_DATA} ${WRKDIST}/c-icap.conf \
		${PREFIX}/share/examples/c-icap/
	${INSTALL_DATA} ${WRKDIST}/c-icap.magic \
		${PREFIX}/share/examples/c-icap/

.include <bsd.port.mk>