[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / multimedia / xbmc

Annotation of ports/multimedia/xbmc/Makefile, Revision 1.1

1.1     ! kirby       1: # $OpenBSD: Makefile.template,v 1.61 2012/03/29 13:41:58 sthen Exp $
        !             2:
        !             3: #ONLY_FOR_ARCHS =      ???
        !             4: #NOT_FOR_ARCHS =       ???
        !             5: #SHARED_ONLY =         ???
        !             6: #COMES_WITH =          ???
        !             7: #BROKEN =              reason
        !             8:
        !             9: #
        !            10: COMMENT =              lala
        !            11: # COMMENT-foo =                ???     for multi packages
        !            12:
        !            13: #
        !            14: DISTNAME =             xbmc-12.3
        !            15: #PKGNAME =             ???
        !            16: #PKGNAME-foo =         ???     for multi packages
        !            17:
        !            18: #SHARED_LIBS =         ???
        !            19:
        !            20: CATEGORIES =           multimedia
        !            21:
        !            22: HOMEPAGE =             http://xbmc.org/
        !            23:
        !            24: #MAINTAINER =          ???
        !            25:
        !            26: # In case of GPL, version number must be appended (e.g. v2, v2+, v3).
        !            27: PERMIT_PACKAGE_CDROM = Yes
        !            28: PERMIT_PACKAGE_FTP =   Yes
        !            29:
        !            30: #WANTLIB =             ???
        !            31:
        !            32: MASTER_SITES =         http://mirrors.xbmc.org/releases/source/
        !            33:
        !            34: MODULES =              lang/python
        !            35: #BUILD_DEPENDS =       ???
        !            36: #RUN_DEPENDS =         ???
        !            37: LIB_DEPENDS =          archivers/lzo2 \
        !            38:                        audio/libcdio \
        !            39:                        audio/libmodplug \
        !            40:                        databases/mysql \
        !            41:                        devel/boost \
        !            42:                        graphics/glew \
        !            43:                        graphics/libmpeg2 \
        !            44:                        multimedia/libbluray \
        !            45:                        net/samba
        !            46: #REGRESS_DEPENDS =     ???
        !            47:
        !            48: #MAKE_FLAGS =          ???
        !            49: #MAKE_ENV =            ???
        !            50: #FAKE_FLAGS =          ???
        !            51: #REGRESS_FLAGS =       ???
        !            52:
        !            53: #SEPARATE_BUILD =      Yes (build in a directory other than WRKSRC)
        !            54: #SEPARATE_BUILD =      flavored (distinct flavors may share a common WRKSRC)
        !            55: USE_GMAKE =            Yes
        !            56: #USE_GROFF =           Yes
        !            57: #USE_LIBTOOL =         Yes
        !            58: CONFIGURE_STYLE =      gnu
        !            59: CONFIGURE_ARGS +=      --enable-external-libraries \
        !            60:                        --enable-external-ffmpeg \
        !            61:                        --enable-dlopen=no \
        !            62:                        --disable-webserver \
        !            63:                        ${CONFIGURE_SHARED}
        !            64: CONFIGURE_ENV +=       CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
        !            65:                        LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
        !            66:                        PYTHON_VERSION=${MODPY_VERSION}
        !            67:
        !            68: AUTOCONF_VERSION =     2.67
        !            69: AUTOMAKE_VERSION =     1.11
        !            70: # config.guess and others are copied here
        !            71: #MODGNU_CONFIG_GUESS_DIRS = ??? (defaults to ${WRKSRC}
        !            72:
        !            73: # Is the build automagic or is it interactive
        !            74: #
        !            75: #IS_INTERACTIVE =              Yes
        !            76: #REGRESS_IS_INTERACTIVE =      Yes
        !            77:
        !            78: # Assume you have one multiple choice flavor: 1 2 3 and switches a b.
        !            79: # You would write
        !            80: #
        !            81: #FLAVORS =     1 2 3 a b
        !            82: #FLAVOR ?=
        !            83: # grab multiple choice value
        !            84: #CHOICE = ${FLAVOR:L:Na:Nb}
        !            85: # check that CHOICE is 1 OR 2 OR 3, or error out
        !            86: #.if ${CHOICE} == "1"
        !            87: # code for 1
        !            88: #.elif ${CHOICE} == "2"
        !            89: # code for 2
        !            90: #.elif ${CHOICE} == "3"
        !            91: # code for 3
        !            92: #.else
        !            93: #ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
        !            94: #.endif
        !            95: # check for switches
        !            96: #.if ${FLAVOR:L:Ma}
        !            97: # code for a
        !            98: #.endif
        !            99: #.if ${FLAVOR:L:Mb}
        !           100: # code for b
        !           101: #.endif
        !           102:
        !           103: #NO_REGRESS =          Yes
        !           104:
        !           105: #CFLAGS =              ???
        !           106: #LDFLAGS =             ???
        !           107: #MAKE_FILE =           ???
        !           108: WRKDIST =              ${WRKDIR}/${DISTNAME}-Frodo
        !           109:
        !           110: #ALL_TARGET =          ???
        !           111: #INSTALL_TARGET =      ???
        !           112: #REGRESS_TARGET =      ???
        !           113:
        !           114: pre-configure:
        !           115:        cd ${WRKSRC} && env AUTOCONF_VERSION=${AUTOCONF_VERSION} \
        !           116:                AUTOMAKE_VERSION=${AUTOMAKE_VERSION} autoreconf -vif
        !           117:
        !           118: .include <bsd.port.mk>

CVSweb