[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / misc / gourmet

File: [local] / ports / misc / gourmet / Makefile (download)

Revision 1.1, Wed Oct 12 05:09:18 2016 UTC (7 years, 6 months ago) by kirby
Branch point for: MAIN

Initial revision

# $OpenBSD: Makefile.template,v 1.73 2016/01/11 09:17:22 sthen Exp $

COMMENT =	recipe organizer and shopping list generator

GH_ACCOUNT =	thinkle
GH_PROJECT =	gourmet
GH_TAGNAME =	0.17.4

MODPY_EGG_VERSION = ${GH_TAGNAME}

CATEGORIES =	misc x11

HOMEPAGE =	http://thinkle.github.io/gourmet/

MAINTAINER = 	Kirill Bychkov <kirby@openbsd.org>

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes

MODULES =		lang/python
BUILD_DEPENDS =		devel/gettext-tools\
			devel/py-distutils-extra \
			textproc/intltool
RUN_DEPENDS =		databases/py-sqlalchemy \
			devel/desktop-file-utils \
			graphics/py-Pillow \
			x11/gtk+3,-guic \
			x11/py-gtk2
LIB_DEPENDS =		
#TEST_DEPENDS =		???

#TEST_TARGET =		???
NO_BUILD=Yes

SUBST_VARS += 		MODPY_SITEPKG

pre-configure:
	${SUBST_CMD} ${WRKSRC}/gourmet/settings.py

.include <bsd.port.mk>