[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / mail / squirrelmail

File: [local] / ports / mail / squirrelmail / Makefile (download)

Revision 1.18, Thu Oct 10 03:57:10 2013 UTC (10 years, 6 months ago) by kirby
Branch: MAIN
CVS Tags: HEAD
Changes since 1.17: +1 -1 lines

fix empty subjects.
default value for htmlspecialchars changed from ISO-8859-1 to UTF-8 in php 5.4 and default htmlspecialchars behaviour is to return empty string once non-utf character is found (if utf/default encoding is used).

# $OpenBSD$

COMMENT =		standards-based webmail package written in PHP

DISTNAME =		squirrelmail-webmail-1.4.22
REVISION = 		1
PKGNAME = 		${DISTNAME:S/-webmail//}

CATEGORIES =		mail www

HOMEPAGE =		http://www.squirrelmail.org/

MAINTAINER =		Kirill Bychkov <kirby@openbsd.org>

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes

MASTER_SITES =		${MASTER_SITE_SOURCEFORGE:=squirrelmail/}

NO_BUILD =		Yes
NO_TEST = 		Yes
PKG_ARCH = 		*

PREFIX = 		/var/www
INSTDIR = 		${PREFIX}/htdocs/squirrelmail

MODULES = 		lang/php
MODPHP_RUNDEP = 	Yes

do-configure:
	# This option hides SquirrelMail version on login page
	echo "\$$hide_sm_attributions = true;" >> ${WRKDIST}/config/config_local.php
	perl -pi -e 's,/var/local/,/var/,g' ${WRKDIST}/config/config_default.php
	mv ${WRKDIST}/config/config_local.php ${WRKDIST}/config/config_local_default.php
	# php-5.4 compatibility
	perl -pi -e 's,hex2bin,convertHex2bin,g' ${WRKDIST}/plugins/mail_fetch/functions.php
do-install:
	${INSTALL_DATA_DIR} ${INSTDIR}
	cd ${WRKDIST}; tar cf - . | tar xf - -C ${INSTDIR}

.include <bsd.port.mk>