[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / mail / squirrelmail

File: [local] / ports / mail / squirrelmail / Makefile (download)

Revision 1.10, Fri Dec 24 05:18:13 2010 UTC (13 years, 4 months ago) by yason
Branch: MAIN
CVS Tags: squirrelmail_1-4-21
Changes since 1.9: +5 -1 lines

handle config_local.php as config, disable version print for security reasons

# $OpenBSD$

COMMENT =		standards-based webmail package written in PHP

DISTNAME =		squirrelmail-1.4.21

CATEGORIES =		mail www

HOMEPAGE =		http://www.squirrelmail.org/

MAINTAINER =		Kirill Bychkov <yason@linklevel.net>

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

MASTER_SITES =		${MASTER_SITE_SOURCEFORGE:=squirrelmail/}

NO_BUILD =		Yes
NO_REGRESS = 		Yes
PKG_ARCH = 		*

PREFIX = 		/var/www
INSTDIR = 		${PREFIX}/htdocs/squirrelmail

RUN_DEPENDS = 		php5-core-*:www/php5/core

do-configure:
	# This option hides SquirrelMail version on login page
	echo "\$$hide_sm_attributions = true;" >> ${WRKDIST}/config/config_local.php
	mv ${WRKDIST}/config/config_local.php ${WRKDIST}/config/config_local_default.php
do-install:
	${INSTALL_DATA_DIR} ${INSTDIR}
	cd ${WRKDIST}; tar cf - . | tar xf - -C ${INSTDIR}

.include <bsd.port.mk>