[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / japanese / gjiten

File: [local] / ports / japanese / gjiten / Makefile (download)

Revision 1.4, Sat Feb 28 22:26:56 2009 UTC (15 years, 2 months ago) by yason
Branch: MAIN
CVS Tags: HEAD
Changes since 1.3: +1 -1 lines

fix typo

# $OpenBSD$

COMMENT = 		gtk+ japanese-english dictionary

DISTNAME = 		gjiten-2.6

CATEGORIES = 		japanese x11

MASTER_SITES = 		http://gjiten.sourceforge.net/

HOMEPAGE = 		http://gjiten.sourceforge.net

# GNU GPLv2
PERMIT_PACKAGE_CDROM = 	Yes
PERMIT_PACKAGE_FTP = 	Yes
PERMIT_DISTFILES_CDROM = Yes
PERMIT_DISTFILES_FTP = 	Yes

MODULES = 		devel/gettext \
			textproc/intltool
WANTLIB = 		ICE ORBit-2 ORBitCosNaming-2 SM X11 Xau \
			Xcomposite Xcursor Xdamage Xdmcp Xext Xfixes \
			Xi Xinerama Xrandr Xrender art_lgpl_2 atk-1.0 \
			bonobo-2 bonobo-activation bonoboui-2 c cairo \
			crypto dbus-1 dbus-glib-1 expat fontconfig \
			freetype gio-2.0 gconf-2 glade-2.0 glib-2.0 \
			glitz gmodule-2.0 gnome-keyring gnomevfs-2 \
			gnomecanvas-2 gobject-2.0 gthread-2.0 intl m \
			pango-1.0 pangocairo-1.0 pangoft2-1.0 pcre \
			pixman-1 png popt pthread ssl util xml2 z

LIB_DEPENDS = 		gailutil,gdk-x11-2.0::x11/gtk+2 \
			gdk_pixbuf-2.0,gtk-x11-2.0::x11/gtk+2 \
			gnome-2::x11/gnome/libgnome \
			gnomeui-2::x11/gnome/libgnomeui \
			:xmlto-*:textproc/xmlto

USE_GMAKE = 		Yes
USE_X11 =		Yes

CONFIGURE_STYLE = 	gnu
CONFIGURE_ARGS = 	\
	--with-gconf-schema-file-dir=${PREFIX}/share/schemas/gjiten \
	--disable-schemas-install
CONFIGURE_ENV +=	CPPFLAGS="-I${LOCALBASE}/include" \
			LDFLAFS="-L${LOCALBASE}/lib"

post-install:
	${INSTALL_DATA_DIR}	${PREFIX}/share/gjiten/dics
	${INSTALL_DATA}	${WRKSRC}/README ${PREFIX}/share/doc/gjiten
	${INSTALL_SCRIPT} ${WRKSRC}/dicfiles/getdics.pl ${PREFIX}/bin

.include <bsd.port.mk>