[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / japanese / gjiten

File: [local] / ports / japanese / gjiten / Makefile (download)

Revision 1.2, Sun Feb 1 19:58:07 2009 UTC (15 years, 3 months ago) by nbrk
Branch: MAIN
Changes since 1.1: +10 -7 lines

install schemas to a correct place;
let post-install to install distribution's README and prepare a directory
for system-wide dictionaries;
disable WANTLIB for now;

# $OpenBSD$

COMMENT=		gtk+ japanese-english dictionary

DISTNAME=		gjiten-2.6

CATEGORIES=		japanese x11

MASTER_SITES=	http://gjiten.sourceforge.net/

HOMEPAGE=	http://gjiten.sourceforge.net

# GNU GPLv2
PERMIT_PACKAGE_CDROM=   Yes
PERMIT_PACKAGE_FTP=     Yes
PERMIT_DISTFILES_CDROM= Yes
PERMIT_DISTFILES_FTP=   Yes

#WANTLIB=	c fontconfig freetype m z X11 Xext Xrender Xrandr expat \
#		Xau Xcomposite Xcursor Xdamage Xdmcp Xfixes Xi Xinerama \
#		gobject-2.0 glib-2.0 gmodule-2.0 glitz png \
#		pango-1.0 pangocairo-1.0 pangoft2-1.0 \
#		atk-1.0 cairo pixman-1

MODULES=	devel/gettext

LIB_DEPENDS=	gdk-x11-2.0,gdk_pixbuf-2.0,gtk-x11-2.0::x11/gtk+2 \
			:xmlto-*:textproc/xmlto

NO_REGRESS=	Yes
USE_GMAKE=	Yes
USE_X11=	Yes

CONFIGURE_STYLE= gnu
CONFIGURE_ARGS+=	\
	--with-gconf-schema-file-dir=${LOCALBASE}/share/schemas/gjiten \
	--disable-schemas-install

post-install:
	${INSTALL_DATA_DIR}	${PREFIX}/share/gjiten/dics
	${INSTALL_DATA}	${WRKSRC}/README ${PREFIX}/share/doc/gjiten
	${INSTALL_SCRIPT} ${WRKSRC}/dicfiles/getdics.pl ${PREFIX}/bin

.include <bsd.port.mk>