[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / japanese / gjiten

File: [local] / ports / japanese / gjiten / Makefile (download)

Revision 1.1, Fri Jan 30 00:36:09 2009 UTC (15 years, 3 months ago) by nbrk
Branch: MAIN

preliminary port of the gjiten, nice Japanese-English (and English-Japanese)
dictionary for GTK+ .
work in progress, but atleast it compiles and runs.

# $OpenBSD$

COMMENT=		gtk+ japanese-english dictionary

DISTNAME=		gjiten-2.6

CATEGORIES=		japanese x11

# developers did not define any sf packages
MASTER_SITES=	http://gjiten.sourceforge.net/

HOMEPAGE=	http://gjiten.sourceforge.net

# GNU GPLv2
PERMIT_PACKAGE_CDROM=   Yes
PERMIT_PACKAGE_FTP=     Yes
PERMIT_DISTFILES_CDROM= Yes
PERMIT_DISTFILES_FTP=   Yes

WANTLIB=	c fontconfig freetype m z X11 Xext Xrender Xrandr expat \
		Xau Xcomposite Xcursor Xdamage Xdmcp Xfixes Xi Xinerama \
		gobject-2.0 glib-2.0 gmodule-2.0 glitz png \
		pango-1.0 pangocairo-1.0 pangoft2-1.0 \
		atk-1.0 cairo pixman-1

MODULES=	devel/gettext

LIB_DEPENDS=	gdk-x11-2.0,gdk_pixbuf-2.0,gtk-x11-2.0::x11/gtk+2 \
			:xmlto-*:textproc/xmlto

NO_REGRESS=	Yes
USE_GMAKE=	Yes
USE_X11=	Yes

CONFIGURE_STYLE= gnu
CONFIGURE_ARGS=	--localedir=${PREFIX}/share

post-install:
	${INSTALL_SCRIPT} ${WRKSRC}/dicfiles/getdics.pl ${PREFIX}/bin

.include <bsd.port.mk>