[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / zint

File: [local] / ports / graphics / zint / Attic / Makefile (download)

Revision 1.1.1.1 (vendor branch), Sat May 7 09:05:29 2011 UTC (13 years, 1 month ago) by yason
Branch: yason
CVS Tags: zint-2_4_1, import
Changes since 1.1: +0 -0 lines

initial import

# $OpenBSD$

COMMENT-main =		barcode generator
COMMENT-x11 = 		barcode generator GUI

DISTNAME =		zint-2.4.1
PKGNAME-main = 		${DISTNAME}
PKGNAME-x11 = 		zint-x11-2.4.1

SHARED_LIBS += 	QZint	0.0 # 2.4
SHARED_LIBS += 	zint	0.0 # 2.4

CATEGORIES =		graphics

HOMEPAGE =		http://www.zint.org.uk

MAINTAINER =		Kirill Bychkov <yason@linklevel.net>

# GPLv3
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

WANTLIB = 		c m png z
WANTLIB-main = 		${WANTLIB}
WANTLIB-x11 = 		${WANTLIB} QtCore QtGui QtXml pthread stdc++ zint

MASTER_SITES =		${MASTER_SITE_SOURCEFORGE:=zint/}

MODULES =		devel/cmake

LIB_DEPENDS = 		graphics/png

SEPARATE_BUILD =	simple
#USE_LIBTOOL =		Yes
CONFIGURE_ARGS =	-DCMAKE_BUILD_TYPE=RELEASE

MULTI_PACKAGES = 	-main

PSEUDO_FLAVORS = 	no_x11
FLAVOR ?=

.if !${FLAVOR:L:Mno_x11}
MULTI_PACKAGES +=       -x11
LIB_DEPENDS-x11 += 	graphics/zint,-main \
			x11/qt4
RUN_DEPENDS-x11 += 	devel/desktop-file-utils

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/applications/
	${INSTALL_DATA_DIR} ${PREFIX}/share/pixmaps/
	${INSTALL_DATA} ${WRKSRC}/zint-qt.desktop ${PREFIX}/share/applications/
	${INSTALL_DATA} ${WRKSRC}/zint.png ${PREFIX}/share/pixmaps/
.endif

NO_REGRESS =		Yes

.include <bsd.port.mk>