[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / zint

Annotation of ports/graphics/zint/Makefile, Revision 1.4

1.1       yason       1: # $OpenBSD$
                      2:
                      3: COMMENT-main =         barcode generator
                      4: COMMENT-x11 =          barcode generator GUI
                      5:
1.2       yason       6: V =                    2.4.3
                      7: DISTNAME =             zint-${V}
1.1       yason       8: PKGNAME-main =                 ${DISTNAME}
1.2       yason       9: PKGNAME-x11 =          zint-x11-${V}
                     10:
                     11: SHARED_ONLY =          Yes
1.1       yason      12:
                     13: SHARED_LIBS +=         QZint   0.0 # 2.4
                     14: SHARED_LIBS +=         zint    0.0 # 2.4
                     15:
                     16: CATEGORIES =           graphics
                     17:
1.2       yason      18: HOMEPAGE =             http://sourceforge.net/projects/zint/
1.1       yason      19:
                     20: MAINTAINER =           Kirill Bychkov <yason@linklevel.net>
                     21:
                     22: # GPLv3
                     23: PERMIT_PACKAGE_CDROM = Yes
                     24: PERMIT_PACKAGE_FTP =   Yes
                     25: PERMIT_DISTFILES_CDROM =Yes
                     26: PERMIT_DISTFILES_FTP = Yes
                     27:
                     28: WANTLIB =              c m png z
                     29: WANTLIB-main =                 ${WANTLIB}
                     30: WANTLIB-x11 =          ${WANTLIB} QtCore QtGui QtXml pthread stdc++ zint
                     31:
                     32: MASTER_SITES =         ${MASTER_SITE_SOURCEFORGE:=zint/}
                     33:
                     34: MODULES =              devel/cmake
                     35:
                     36: LIB_DEPENDS =          graphics/png
                     37:
                     38: CONFIGURE_ARGS =       -DCMAKE_BUILD_TYPE=RELEASE
                     39:
                     40: MULTI_PACKAGES =       -main
                     41:
                     42: PSEUDO_FLAVORS =       no_x11
                     43: FLAVOR ?=
                     44:
1.4     ! yason      45: .if !${FLAVOR:Mno_x11}
1.1       yason      46: MULTI_PACKAGES +=       -x11
                     47: LIB_DEPENDS-x11 +=     graphics/zint,-main \
                     48:                        x11/qt4
                     49: RUN_DEPENDS-x11 +=     devel/desktop-file-utils
                     50:
                     51: post-install:
                     52:        ${INSTALL_DATA_DIR} ${PREFIX}/share/applications/
                     53:        ${INSTALL_DATA_DIR} ${PREFIX}/share/pixmaps/
                     54:        ${INSTALL_DATA} ${WRKSRC}/zint-qt.desktop ${PREFIX}/share/applications/
                     55:        ${INSTALL_DATA} ${WRKSRC}/zint.png ${PREFIX}/share/pixmaps/
                     56: .endif
                     57:
                     58: NO_REGRESS =           Yes
                     59:
                     60: .include <bsd.port.mk>

CVSweb