[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / zint

Annotation of ports/graphics/zint/Makefile, Revision 1.1.1.1

1.1       yason       1: # $OpenBSD$
                      2:
                      3: COMMENT-main =         barcode generator
                      4: COMMENT-x11 =          barcode generator GUI
                      5:
                      6: DISTNAME =             zint-2.4.1
                      7: PKGNAME-main =                 ${DISTNAME}
                      8: PKGNAME-x11 =          zint-x11-2.4.1
                      9:
                     10: SHARED_LIBS +=         QZint   0.0 # 2.4
                     11: SHARED_LIBS +=         zint    0.0 # 2.4
                     12:
                     13: CATEGORIES =           graphics
                     14:
                     15: HOMEPAGE =             http://www.zint.org.uk
                     16:
                     17: MAINTAINER =           Kirill Bychkov <yason@linklevel.net>
                     18:
                     19: # GPLv3
                     20: PERMIT_PACKAGE_CDROM = Yes
                     21: PERMIT_PACKAGE_FTP =   Yes
                     22: PERMIT_DISTFILES_CDROM =Yes
                     23: PERMIT_DISTFILES_FTP = Yes
                     24:
                     25: WANTLIB =              c m png z
                     26: WANTLIB-main =                 ${WANTLIB}
                     27: WANTLIB-x11 =          ${WANTLIB} QtCore QtGui QtXml pthread stdc++ zint
                     28:
                     29: MASTER_SITES =         ${MASTER_SITE_SOURCEFORGE:=zint/}
                     30:
                     31: MODULES =              devel/cmake
                     32:
                     33: LIB_DEPENDS =          graphics/png
                     34:
                     35: SEPARATE_BUILD =       simple
                     36: #USE_LIBTOOL =         Yes
                     37: CONFIGURE_ARGS =       -DCMAKE_BUILD_TYPE=RELEASE
                     38:
                     39: MULTI_PACKAGES =       -main
                     40:
                     41: PSEUDO_FLAVORS =       no_x11
                     42: FLAVOR ?=
                     43:
                     44: .if !${FLAVOR:L:Mno_x11}
                     45: MULTI_PACKAGES +=       -x11
                     46: LIB_DEPENDS-x11 +=     graphics/zint,-main \
                     47:                        x11/qt4
                     48: RUN_DEPENDS-x11 +=     devel/desktop-file-utils
                     49:
                     50: post-install:
                     51:        ${INSTALL_DATA_DIR} ${PREFIX}/share/applications/
                     52:        ${INSTALL_DATA_DIR} ${PREFIX}/share/pixmaps/
                     53:        ${INSTALL_DATA} ${WRKSRC}/zint-qt.desktop ${PREFIX}/share/applications/
                     54:        ${INSTALL_DATA} ${WRKSRC}/zint.png ${PREFIX}/share/pixmaps/
                     55: .endif
                     56:
                     57: NO_REGRESS =           Yes
                     58:
                     59: .include <bsd.port.mk>

CVSweb