[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / uniconvertor

File: [local] / ports / graphics / uniconvertor / Makefile (download)

Revision 1.2, Wed Feb 10 07:32:48 2010 UTC (14 years, 3 months ago) by yason
Branch: MAIN
Changes since 1.1: +7 -1 lines

update license marker and install license files

# $OpenBSD$

COMMENT =		universal vector graphics translator

V = 			1.1.4
DISTNAME =		uniconvertor-${V}

CATEGORIES =		graphics

HOMEPAGE =		http://sk1project.org/

#MAINTAINER =		???

# GPLv2/LGPLv2
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

MASTER_SITES =		http://sk1project.org/downloads/uniconvertor/v${V}/

MODULES =		lang/python

NO_REGRESS =		Yes

WRKDIST = 		${WRKDIR}/UniConvertor-${V}

post-patch:
	perl -pi -e 's,python,${MODPY_BIN},g' ${WRKSRC}/src/uniconv
	perl -pi -e 's,/usr/bin/python,${MODPY_BIN},g' ${WRKSRC}/src/__init__.py

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/doc/uniconvertor
.for i in COPYRIGHTS  GNU_GPL_v2  GNU_LGPL_v2
	${INSTALL_DATA} ${WRKSRC}/src/$i ${PREFIX}/share/doc/uniconvertor/
.endfor

.include <bsd.port.mk>