[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / simgear

File: [local] / ports / graphics / simgear / Attic / Makefile (download)

Revision 1.7, Wed Dec 8 05:05:24 2010 UTC (13 years, 5 months ago) by yason
Branch: MAIN
Changes since 1.6: +0 -1 lines

remove USE_X11

# $OpenBSD$

COMMENT =		quickly assembling 3d sims and games

DISTNAME =		SimGear-2.0.0
PKGNAME =		${DISTNAME:L}

CATEGORIES =		graphics

HOMEPAGE =		http://www.simgear.org/

#MAINTAINER =		???

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

#WANTLIB =		???

MASTER_SITES =		ftp://mirrors.ibiblio.org/pub/mirrors/simgear/ftp/Source/
#MASTER_SITES0 = 	ftp://goflyflightgear.com/simgear/Source/

BUILD_DEPENDS = 	graphics/osg
LIB_DEPENDS =		audio/openal \
			audio/freealut \
			devel/boost \
			devel/plib \
			graphics/glut

USE_LIBTOOL =		Yes
CONFIGURE_STYLE =	gnu
CONFIGURE_ARGS +=	--with-jpeg-factory
CONFIGURE_ENV += 	CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
			LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -pthread"

.include <bsd.port.mk>