[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / simgear

File: [local] / ports / graphics / simgear / Attic / Makefile (download)

Revision 1.1, Sun Aug 30 08:30:45 2009 UTC (14 years, 9 months ago) by yason
Branch: MAIN

Initial revision

# $OpenBSD$
#ONLY_FOR_ARCHS =	???
#NOT_FOR_ARCHS =	???
#SHARED_ONLY =		???
#COMES_WITH =		???

COMMENT =		quickly assembling 3d sims and games

DISTNAME =		SimGear-1.9.1
PKGNAME =		${DISTNAME:L}

#SHARED_LIBS =		???

CATEGORIES =		graphics

HOMEPAGE =		http://www.simgear.org/

#MAINTAINER =		???

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

#WANTLIB =		???

MASTER_SITES =		ftp://ftp.simgear.org/pub/simgear/Source/

#BUILD_DEPENDS =	???
#RUN_DEPENDS =		???
LIB_DEPENDS =		::audio/openal-soft \
			::devel/plib \
			::graphics/freeglut

#MAKE_FLAGS =		???
#MAKE_ENV =		???
#FAKE_FLAGS =		???
#REGRESS_FLAGS =	???

USE_X11 =		Yes
#USE_GMAKE =		Yes
USE_LIBTOOL =		Yes
CONFIGURE_STYLE =	gnu
CONFIGURE_ARGS +=	${CONFIGURE_SHARED} \
			--with-jpeg-factory
CONFIGURE_ENV += 	CPPFLAGS=-I${LOCALBASE}/include \
			LDFLAGS="-L${LOCALBASE}/lib -pthread"

#AUTOCONF_VERSION =	2.61
#AUTOMAKE_VERSION =	??? (defaults to 1.4)
#MODGNU_CONFIG_GUESS_DIRS = ??? (defaults to ${WRKSRC}

#NO_REGRESS =		Yes

#CFLAGS =		???
#LDFLAGS =		???

.include <bsd.port.mk>