[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / phatch

File: [local] / ports / graphics / phatch / Attic / Makefile (download)

Revision 1.4, Sun Nov 16 21:01:24 2014 UTC (9 years, 6 months ago) by kirby
Branch: MAIN
Changes since 1.3: +18 -15 lines

seems to be ready finally

# $OpenBSD$

COMMENT =		photo batch processor

DISTNAME =		phatch-0.2.7.1

CATEGORIES =		graphics

HOMEPAGE =		http://photobatch.stani.be/

MAINTAINER =		Kirill Bychkov <kirby@openbsd.org>

# GPLv3
PERMIT_PACKAGE_CDROM =	Yes

MASTER_SITES =		${HOMEPAGE}/download/package/

MODULES =		lang/python
RUN_DEPENDS =		devel/desktop-file-utils \
			graphics/py-Pillow \
			misc/shared-mime-info \
			x11/gtk+2,-guic \
			x11/py-wxPython

MODPY_ADJ_FILES = 	setup.py bin/phatch docs/update.py phatch/lib/*.py \
			phatch/lib/pyWx/dialogsInspector.py phatch/other/*.py \
			tests/*.py tests/test_suite/*.py \
			tools/change_tags.py phatch/phatch.py

NO_BUILD =		Yes
NO_TEST =		Yes

WRKDIST =		${WRKDIR}/phatch-0.2.7

# Switch from py-Image to py-Pillow
post-extract:
	find ${WRKSRC} -name *.py -exec \
		perl -pi -e 's|import Image|from PIL import Image|g' {} \;
	perl -pi -e 's|import PngImagePlugin|from PIL import PngImagePlugin|g' \
		${WRKSRC}/phatch/lib/thumbnail.py
	perl -pi -e 's|from PIL from PIL|from PIL|g' \
		${WRKSRC}/phatch/actions/convert_mode.py
	perl -pi -e 's|from PIL ||g' \
		${WRKSRC}/phatch/other/pyWx/TextCtrlAutoComplete.py

.include <bsd.port.mk>