[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / osg

File: [local] / ports / graphics / osg / Attic / Makefile (download)

Revision 1.3, Thu Aug 6 06:20:08 2009 UTC (14 years, 9 months ago) by yason
Branch: MAIN
Changes since 1.2: +3 -0 lines

some missed dependencies

# $OpenBSD:$
#ONLY_FOR_ARCHS =	???
#NOT_FOR_ARCHS =	???
#SHARED_ONLY =		???
#COMES_WITH =		???

COMMENT =		high performance 3D graphics toolkit

DISTNAME =		OpenSceneGraph-2.8.2

SHARED_LIBS =		OpenTreads	2.4 \
			osg		2.8 \
			osgAnimation	2.8 \
			osgDB		2.8 \
			osgFX		2.8 \
			osgGA		2.8 \
			osgManipulator	2.8 \
			osgParticle	2.8 \
			osgShadow	2.8 \
			osgSim		2.8 \
			osgTerrain	2.8 \
			osgText		2.8 \
			osgUtil		2.8 \
			osgViewer	2.8 \
			osgVolume	2.8 \
			osgWidget	2.8

CATEGORIES =		graphics devel

HOMEPAGE =		http://www.openscenegraph.org/

#MAINTAINER =		???

# OSGPL
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

WANTLIB = 		GL GLU ICE SM X11 Xau Xdmcp Xext Xrandr Xrender c expat \
			fontconfig freetype gif intl m pixman-1 pthread stdc++ z

MASTER_SITES =		http://www.openscenegraph.org/downloads/developer_releases/
EXTRACT_SUFX =		.zip

MODULES =		devel/cmake
CONFIGURE_ARGS = 	-DBUILD_OSG_EXAMPLES:BOOL=ON

BUILD_DEPENDS = 	::x11/wxWidgets

LIB_DEPENDS =		Half.>=4::graphics/ilmbase \
			IlmImf.>=4::graphics/openexr \
			cairo.>=9::graphics/cairo \
			curl.>=13::net/curl \
			gdal.>=14::geo/gdal \
			gdk_pixbuf-2.0.>=1400::graphics/gdk-pixbuf \
			glib-2.0.>=1800::devel/glib2 \
			glitz.>=2::graphics/glitz \
			gmodule-2.0.>=1800,gobject-2.0.>=1800::devel/glib2 \
			iconv.>=6::converters/libiconv \
			jasper.>=2::graphics/jasper \
			jpeg.>=62::graphics/jpeg \
			png.>=8::graphics/png \
			poppler-glib::print/poppler,no_qt,no_qt4 \
			rsvg-2.>=24::x11/gnome/librsvg \
			tiff.>=38::graphics/tiff

USE_X11 =		Yes
USE_LIBTOOL =		Yes

NO_REGRESS =		Yes

#CFLAGS =		???
#LDFLAGS =		???
#MAKE_FILE =		???
#PKG_ARCH =		???

.include <bsd.port.mk>