[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / osg

Annotation of ports/graphics/osg/Makefile, Revision 1.1

1.1     ! yason       1: # $OpenBSD:$
        !             2: #ONLY_FOR_ARCHS =      ???
        !             3: #NOT_FOR_ARCHS =       ???
        !             4: #SHARED_ONLY =         ???
        !             5: #COMES_WITH =          ???
        !             6: #BROKEN =              reason
        !             7:
        !             8: COMMENT =              high performance 3D graphics toolkit
        !             9: # COMMENT-foo =                ???     for multi packages
        !            10:
        !            11: DISTNAME =             OpenSceneGraph-2.8.1
        !            12: #PKGNAME =             ???
        !            13: #PKGNAME-foo =         ???     for multi packages
        !            14:
        !            15: SHARED_LIBS =          OpenThreads 2.4 \
        !            16:                        osg 2.8 \
        !            17:                        osgAnimation 2.8 \
        !            18:                        osgDB 2.8 \
        !            19:                        osgFX 2.8 \
        !            20:                        osgGA 2.8 \
        !            21:                        osgManipulator 2.8 \
        !            22:                        osgParticle 2.8 \
        !            23:                        osgShadow 2.8 \
        !            24:                        osgSim 2.8 \
        !            25:                        osgTerrain 2.8 \
        !            26:                        osgText 2.8 \
        !            27:                        osgUtil 2.8 \
        !            28:                        osgViewer 2.8 \
        !            29:                        osgVolume 2.8 \
        !            30:                        osgWidget 2.8
        !            31:
        !            32: CATEGORIES =           graphics devel
        !            33:
        !            34: HOMEPAGE =             http://www.openscenegraph.org/
        !            35:
        !            36: #MAINTAINER =          ???
        !            37:
        !            38: #OSGPL
        !            39: PERMIT_PACKAGE_CDROM = Yes
        !            40: PERMIT_PACKAGE_FTP =   Yes
        !            41: PERMIT_DISTFILES_CDROM =Yes
        !            42: PERMIT_DISTFILES_FTP = Yes
        !            43:
        !            44: WANTLIB =              GL GLU ICE SM X11 Xau Xdmcp Xext Xrandr Xrender c expat \
        !            45:                        fontconfig freetype gif intl m pixman-1 pthread stdc++ z
        !            46:
        !            47: MASTER_SITES =         http://www.openscenegraph.org/downloads/stable_releases/OpenSceneGraph-2.8.1/source/
        !            48: EXTRACT_SUFX =         .zip
        !            49:
        !            50: MODULES =              devel/cmake
        !            51: LIB_DEPENDS =          cairo.>=9::graphics/cairo \
        !            52:                        curl.>=13::net/curl \
        !            53:                        gdal.>=14::geo/gdal \
        !            54:                        gdk_pixbuf-2.0.>=1400::graphics/gdk-pixbuf \
        !            55:                        glib-2.0.>=1800::devel/glib2 \
        !            56:                        glitz.>=2::graphics/glitz \
        !            57:                        gmodule-2.0.>=1800,gobject-2.0.>=1800::devel/glib2 \
        !            58:                        iconv.>=6::converters/libiconv \
        !            59:                        jasper.>=2::graphics/jasper \
        !            60:                        jpeg.>=62::graphics/jpeg \
        !            61:                        png.>=8::graphics/png \
        !            62:                        rsvg-2.>=24::x11/gnome/librsvg \
        !            63:                        tiff.>=38::graphics/tiff
        !            64:
        !            65: USE_X11 =              Yes
        !            66: USE_LIBTOOL =          Yes
        !            67: #CONFIGURE_STYLE =     gnu
        !            68: #CONFIGURE_SCRIPT =    ??? (if other than configure)
        !            69: #CONFIGURE_ARGS +=     ${CONFIGURE_SHARED}
        !            70: #CONFIGURE_ENV =       ???
        !            71:
        !            72: #FLAVORS =     1 2 3 a b
        !            73: #FLAVOR ?=
        !            74: # grab multiple choice value
        !            75: #CHOICE = ${FLAVOR:L:Na:Nb}
        !            76: # check that CHOICE is 1 OR 2 OR 3, or error out
        !            77: #.if ${CHOICE} == "1"
        !            78: # code for 1
        !            79: #.elif ${CHOICE} == "2"
        !            80: # code for 2
        !            81: #.elif ${CHOICE} == "3"
        !            82: # code for 3
        !            83: #.else
        !            84: #ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
        !            85: #.endif
        !            86: # check for switches
        !            87: #.if ${FLAVOR:L:Ma}
        !            88: # code for a
        !            89: #.endif
        !            90: #.if ${FLAVOR:L:Mb}
        !            91: # code for b
        !            92: #.endif
        !            93:
        !            94: NO_REGRESS =           Yes
        !            95:
        !            96: #CFLAGS =              ???
        !            97: #LDFLAGS =             ???
        !            98: #MAKE_FILE =           ???
        !            99: #PKG_ARCH =            ???
        !           100:
        !           101: .include <bsd.port.mk>

CVSweb