[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / ogre3d

Annotation of ports/graphics/ogre3d/Makefile, Revision 1.2

1.1       yason       1: # $OpenBSD$
                      2:
                      3: COMMENT =              open-source graphics rendering engine
                      4:
                      5: DISTNAME =             ogre_src_v1-7-1
                      6: PKGNAME =              ${DISTNAME:S/-/./g:S/_src_v/-/}
                      7:
                      8: SHARED_LIBS +=                 OgreMain                0.0
                      9: SHARED_LIBS +=                 OgrePaging              0.0
                     10: SHARED_LIBS +=                 OgreProperty            0.0
                     11: SHARED_LIBS +=                 OgreRTShaderSystem      0.0
                     12: SHARED_LIBS +=                 OgreTerrain             0.0
                     13:
                     14: CATEGORIES =           graphics
                     15:
                     16: HOMEPAGE =             http://www.ogre3d.org/
                     17:
1.2     ! yason      18: #MAINTAINER =          Kirill Bychkov <yason@linklevel.net>
1.1       yason      19:
                     20: # MIT
                     21: PERMIT_PACKAGE_CDROM = Yes
                     22: PERMIT_PACKAGE_FTP =   Yes
                     23: PERMIT_DISTFILES_CDROM =Yes
                     24: PERMIT_DISTFILES_FTP = Yes
                     25:
                     26: MASTER_SITES =         ${MASTER_SITE_SOURCEFORGE:=ogre/}
                     27: EXTRACT_SUFX =         .tar.bz2
                     28:
1.2     ! yason      29: WANTLIB += GL GLU ICE SM X11 Xaw Xext Xrandr Xt boost_date_time-mt
        !            30: WANTLIB += boost_thread-mt c freeimage freetype m pthread stdc++ z zzip
1.1       yason      31:
                     32: MODULES =              devel/cmake
1.2     ! yason      33: BUILD_DEPENDS =                ::devel/doxygen
        !            34: LIB_DEPENDS =          ::archivers/zziplib \
        !            35:                        ::devel/boost \
        !            36:                        ::devel/ois \
        !            37:                        ::graphics/freeimage
1.1       yason      38:
                     39: SEPARATE_BUILD =       concurrent
                     40: USE_X11 =              Yes
                     41: USE_LIBTOOL =          Yes
1.2     ! yason      42: #CONFIGURE_ARGS +=     -DCMAKE_BUILD_TYPE=Release -DOGRE_BUILD_SAMPLES=TRUE
        !            43: #                      -DOGRE_BUILD_TESTS=TRUE
1.1       yason      44: NO_REGRESS =           Yes
                     45:
                     46: .include <bsd.port.mk>

CVSweb