[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / ogre3d

Annotation of ports/graphics/ogre3d/Makefile, Revision 1.1

1.1     ! yason       1: # $OpenBSD$
        !             2:
        !             3: COMMENT =              open-source graphics rendering engine
        !             4:
        !             5: DISTNAME =             ogre_src_v1-7-1
        !             6: PKGNAME =              ${DISTNAME:S/-/./g:S/_src_v/-/}
        !             7:
        !             8: SHARED_LIBS +=                 OgreMain                0.0
        !             9: SHARED_LIBS +=                 OgrePaging              0.0
        !            10: SHARED_LIBS +=                 OgreProperty            0.0
        !            11: SHARED_LIBS +=                 OgreRTShaderSystem      0.0
        !            12: SHARED_LIBS +=                 OgreTerrain             0.0
        !            13:
        !            14: CATEGORIES =           graphics
        !            15:
        !            16: HOMEPAGE =             http://www.ogre3d.org/
        !            17:
        !            18: #MAINTAINER =          ???
        !            19:
        !            20: # MIT
        !            21: PERMIT_PACKAGE_CDROM = Yes
        !            22: PERMIT_PACKAGE_FTP =   Yes
        !            23: PERMIT_DISTFILES_CDROM =Yes
        !            24: PERMIT_DISTFILES_FTP = Yes
        !            25:
        !            26: MASTER_SITES =         ${MASTER_SITE_SOURCEFORGE:=ogre/}
        !            27: EXTRACT_SUFX =         .tar.bz2
        !            28:
        !            29: WANTLIB += GL GLU ICE SM X11 Xaw Xext Xrandr Xt c freetype m pthread
        !            30: WANTLIB += stdc++ z
        !            31:
        !            32: MODULES =              devel/cmake
        !            33: #BUILD_DEPENDS =       ???
        !            34: #RUN_DEPENDS =         ???
        !            35: LIB_DEPENDS =          zzip::archivers/zziplib \
        !            36:                        boost_date_time-mt,boost_thread-mt::devel/boost \
        !            37:                        freeimage::graphics/freeimage
        !            38:
        !            39: SEPARATE_BUILD =       concurrent
        !            40: USE_X11 =              Yes
        !            41: USE_LIBTOOL =          Yes
        !            42: #CONFIGURE_ARGS +=     ${CONFIGURE_SHARED}
        !            43: #CONFIGURE_ENV =       ???
        !            44:
        !            45: NO_REGRESS =           Yes
        !            46:
        !            47: .include <bsd.port.mk>

CVSweb