[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / luminance

File: [local] / ports / graphics / luminance / Attic / Makefile (download)

Revision 1.4, Wed Dec 8 05:01:29 2010 UTC (13 years, 5 months ago) by yason
Branch: MAIN
CVS Tags: luminance-2_0_1
Changes since 1.3: +6 -6 lines

new DEPENDS style

# $OpenBSD$
COMMENT =		application that aims to provide a workflow for HDR imaging

DISTNAME =		luminance-v2.0.1
PKGNAME = 		${DISTNAME:S/v//}

CATEGORIES =		graphics

HOMEPAGE =		http://qtpfsgui.sourceforge.net/

#MAINTAINER =		???

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

WANTLIB =		Half Iex IlmImf Imath QtGui QtWebKit QtXml \
			c  exiv2 fftw3f gsl gslcblas m pthread stdc++ tiff

MASTER_SITES =		${MASTER_SITE_SOURCEFORGE:=qtpfsgui/}

MODULES =		x11/qt4
RUN_DEPENDS =		devel/desktop-file-utils
LIB_DEPENDS =		devel/gsl \
			graphics/openexr \
			graphics/exiv2 \
			graphics/tiff \
			math/fftw3,float

FAKE_FLAGS = 		INSTALL_ROOT=${WRKINST}

NO_REGRESS =		Yes

do-build:
	cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${LOCALBASE}/bin/qmake4 PREFIX=${PREFIX}

.include <bsd.port.mk>