[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / luminance

File: [local] / ports / graphics / luminance / Attic / Makefile (download)

Revision 1.9, Sun Nov 20 17:23:00 2011 UTC (12 years, 6 months ago) by yason
Branch: MAIN
Changes since 1.8: +1 -1 lines

add icon-goo in PLIST and set libraw version

# $OpenBSD$
COMMENT =		application that aims to provide a workflow for HDR imaging

V = 			2.1.0
DISTNAME =		luminance-hdr-${V}
PKGNAME = 		${DISTNAME:S/-hdr//}

CATEGORIES =		graphics

HOMEPAGE =		http://qtpfsgui.sourceforge.net/

#MAINTAINER =		???

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

MASTER_SITES =		${MASTER_SITE_SOURCEFORGE:=qtpfsgui/}

WANTLIB += Half Iex IlmImf QtGui QtSql QtWebKit QtXml c exiv2
WANTLIB += fftw3f gsl gslcblas lcms m pthread raw_r stdc++ tiff

MODULES =		devel/cmake x11/qt4
RUN_DEPENDS =		devel/desktop-file-utils \
			x11/qt4,-sqlite
LIB_DEPENDS =		devel/gsl \
			graphics/openexr \
			graphics/exiv2 \
			graphics/libraw>=0.13.8 \
			graphics/tiff \
			math/fftw3,float

CONFIGURE_ARGS += 	-DCMAKE_BUILD_TYPE=RELEASE \
			-DCMAKE_EXE_LINKER_FLAGS=-pthread

NO_REGRESS =		Yes

.include <bsd.port.mk>