[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / libiptcdata

Annotation of ports/graphics/libiptcdata/Makefile, Revision 1.1.1.1

1.1       yason       1: # $OpenBSD$
                      2:
                      3: COMMENT-main =         manipulating with IPTC metadata
                      4: COMMENT-python =       libiptcdata Python bindings
                      5:
                      6: DISTNAME =             libiptcdata-1.0.4
                      7: PKGNAME-main =         ${DISTNAME}
                      8: PKGNAME-python =       py-${DISTNAME}
                      9:
                     10: SHARED_LIBS =          iptcdata        0.0 # 3.3
                     11:
                     12: CATEGORIES =           graphics
                     13:
                     14: HOMEPAGE =             http://libiptcdata.sourceforge.net/
                     15:
                     16: #MAINTAINER =          ???
                     17:
                     18: # LGPL
                     19: PERMIT_PACKAGE_CDROM = Yes
                     20: PERMIT_PACKAGE_FTP =   Yes
                     21: PERMIT_DISTFILES_CDROM =Yes
                     22: PERMIT_DISTFILES_FTP = Yes
                     23:
                     24: WANTLIB =              m util
                     25: WANTLIB-main =                 ${WANTLIB} c iconv intl pthread
                     26: WANTLIB-python =       ${WANTLIB} iptcdata
                     27:
                     28: MASTER_SITES =         ${MASTER_SITE_SOURCEFORGE:=libiptcdata/}
                     29:
                     30: MODULES =              lang/python
                     31: LIB_DEPENDS-main =     devel/gettext
                     32: LIB_DEPENDS-python =   graphics/libiptcdata,-main
                     33:
                     34: USE_LIBTOOL =          Yes
                     35: CONFIGURE_STYLE =      gnu
                     36: CONFIGURE_ARGS +=      ${CONFIGURE_SHARED} \
                     37:                        --enable-python
                     38: CONFIGURE_ENV +=       PYTHON_VERSION=${MODPY_VERSION} \
                     39:                        LDFLAGS="-L${LOCALBASE}/lib -pthread -lm -lutil"
                     40:
                     41: MULTI_PACKAGES =       -main -python
                     42:
                     43: NO_REGRESS =           Yes
                     44:
                     45: .include <bsd.port.mk>

CVSweb