[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / libcaca

File: [local] / ports / graphics / libcaca / Attic / Makefile (download)

Revision 1.1, Fri Sep 27 12:48:11 2013 UTC (10 years, 9 months ago) by kirby
Branch: MAIN

Initial revision

# $OpenBSD: Makefile.template,v 1.67 2013/07/10 15:22:23 bcallah Exp $
# $FreeBSD/NetBSD: credit FreeBSD/NetBSD if thats where the port came from $
# Original from: credit the original author here
#
# Replace ??? with appropriate values
# Remove extraneous comments before commit.

# Reasons why the port/package shouldn't be built
#
#ONLY_FOR_ARCHS =	???
#NOT_FOR_ARCHS =	???
#SHARED_ONLY =		???
#COMES_WITH =		???
#BROKEN =		reason

#
COMMENT =		???
# COMMENT-foo =		???	for multi packages

#
DISTNAME =		libcaca-0.99.beta18
#PKGNAME =		???
#PKGNAME-foo =		???	for multi packages

SHARED_LIBS += 		caca++	0.0 # 0.0
SHARED_LIBS += 		caca	0.0 # 0.0

CATEGORIES =		graphics

HOMEPAGE =		http://caca.zoy.org/wiki/libcaca

#MAINTAINER =		???

# Setting PERMIT_PACKAGE_CDROM=Yes defaults other PERMIT_* variables to Yes.
PERMIT_PACKAGE_CDROM =	Yes

WANTLIB += X11 c m ncursesw stdc++ xcb z

MASTER_SITES =		http://caca.zoy.org/files/libcaca/

MODULES =		lang/python
#BUILD_DEPENDS =	???
#RUN_DEPENDS =		???
#LIB_DEPENDS =		???

#MAKE_FLAGS =		???
#MAKE_ENV =		???
#FAKE_FLAGS =		???

#SEPARATE_BUILD =	Yes (build in a directory other than WRKSRC)
#SEPARATE_BUILD =	flavored (distinct flavors may share a common WRKSRC)
#USE_GROFF =		Yes
#USE_LIBTOOL=		gnu
CONFIGURE_STYLE =	gnu
#CONFIGURE_SCRIPT =	??? (if other than configure)
CONFIGURE_ARGS +=	${CONFIGURE_SHARED}
#CONFIGURE_ENV =	???

#FLAVORS =	1 2 3 a b
#FLAVOR ?=
# grab multiple choice value
#CHOICE = ${FLAVOR:Na:Nb}
# check that CHOICE is 1 OR 2 OR 3, or error out
#.if ${CHOICE} == "1"
# code for 1
#.elif ${CHOICE} == "2"
# code for 2
#.elif ${CHOICE} == "3"
# code for 3
#.else
#ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
#.endif
# check for switches
#.if ${FLAVOR:Ma}
# code for a
#.endif
#.if ${FLAVOR:Mb}
# code for b
#.endif

.include <bsd.port.mk>