[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / libcaca

Annotation of ports/graphics/libcaca/Makefile, Revision 1.1.1.1

1.1       kirby       1: # $OpenBSD: Makefile.template,v 1.67 2013/07/10 15:22:23 bcallah Exp $
                      2: # $FreeBSD/NetBSD: credit FreeBSD/NetBSD if thats where the port came from $
                      3: # Original from: credit the original author here
                      4: #
                      5: # Replace ??? with appropriate values
                      6: # Remove extraneous comments before commit.
                      7:
                      8: # Reasons why the port/package shouldn't be built
                      9: #
                     10: #ONLY_FOR_ARCHS =      ???
                     11: #NOT_FOR_ARCHS =       ???
                     12: #SHARED_ONLY =         ???
                     13: #COMES_WITH =          ???
                     14: #BROKEN =              reason
                     15:
                     16: #
                     17: COMMENT =              ???
                     18: # COMMENT-foo =                ???     for multi packages
                     19:
                     20: #
                     21: DISTNAME =             libcaca-0.99.beta18
                     22: #PKGNAME =             ???
                     23: #PKGNAME-foo =         ???     for multi packages
                     24:
                     25: SHARED_LIBS +=                 caca++  0.0 # 0.0
                     26: SHARED_LIBS +=                 caca    0.0 # 0.0
                     27:
                     28: CATEGORIES =           graphics
                     29:
                     30: HOMEPAGE =             http://caca.zoy.org/wiki/libcaca
                     31:
                     32: #MAINTAINER =          ???
                     33:
                     34: # Setting PERMIT_PACKAGE_CDROM=Yes defaults other PERMIT_* variables to Yes.
                     35: PERMIT_PACKAGE_CDROM = Yes
                     36:
                     37: WANTLIB += X11 c m ncursesw stdc++ xcb z
                     38:
                     39: MASTER_SITES =         http://caca.zoy.org/files/libcaca/
                     40:
                     41: MODULES =              lang/python
                     42: #BUILD_DEPENDS =       ???
                     43: #RUN_DEPENDS =         ???
                     44: #LIB_DEPENDS =         ???
                     45:
                     46: #MAKE_FLAGS =          ???
                     47: #MAKE_ENV =            ???
                     48: #FAKE_FLAGS =          ???
                     49:
                     50: #SEPARATE_BUILD =      Yes (build in a directory other than WRKSRC)
                     51: #SEPARATE_BUILD =      flavored (distinct flavors may share a common WRKSRC)
                     52: #USE_GROFF =           Yes
                     53: #USE_LIBTOOL=          gnu
                     54: CONFIGURE_STYLE =      gnu
                     55: #CONFIGURE_SCRIPT =    ??? (if other than configure)
                     56: CONFIGURE_ARGS +=      ${CONFIGURE_SHARED}
                     57: #CONFIGURE_ENV =       ???
                     58:
                     59: #FLAVORS =     1 2 3 a b
                     60: #FLAVOR ?=
                     61: # grab multiple choice value
                     62: #CHOICE = ${FLAVOR:Na:Nb}
                     63: # check that CHOICE is 1 OR 2 OR 3, or error out
                     64: #.if ${CHOICE} == "1"
                     65: # code for 1
                     66: #.elif ${CHOICE} == "2"
                     67: # code for 2
                     68: #.elif ${CHOICE} == "3"
                     69: # code for 3
                     70: #.else
                     71: #ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
                     72: #.endif
                     73: # check for switches
                     74: #.if ${FLAVOR:Ma}
                     75: # code for a
                     76: #.endif
                     77: #.if ${FLAVOR:Mb}
                     78: # code for b
                     79: #.endif
                     80:
                     81: .include <bsd.port.mk>

CVSweb