[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / jp2a

Annotation of ports/graphics/jp2a/Makefile, Revision 1.7

1.1       yason       1: # $OpenBSD$
                      2:
                      3: COMMENT =              small utility that converts JPG images to ASCII
                      4:
                      5: DISTNAME =             jp2a-1.0.6
                      6:
                      7: CATEGORIES =           graphics
                      8:
                      9: HOMEPAGE =             http://csl.sublevel3.org/jp2a/
                     10:
1.3       yason      11: MAINTAINER =           Kirill Bychkov <yason@linklevel.net>
1.1       yason      12:
                     13: # GPL
                     14: PERMIT_PACKAGE_CDROM =         Yes
                     15: PERMIT_PACKAGE_FTP =   Yes
                     16: PERMIT_DISTFILES_CDROM = Yes
                     17: PERMIT_DISTFILES_FTP =         Yes
                     18:
                     19: MASTER_SITES=           ${MASTER_SITE_SOURCEFORGE:=jp2a/}
                     20:
1.6       yason      21: WANTLIB =              c crypto curl idn jpeg ncurses ssl z
1.7     ! yason      22: LIB_DEPENDS =          graphics/jpeg \
        !            23:                        devel/libidn \
        !            24:                        net/curl
1.1       yason      25:
1.7     ! yason      26: REGRESS_DEPENDS =      shells/bash
1.5       yason      27:
1.4       yason      28: CONFIGURE_STYLE =      gnu
1.1       yason      29:
                     30: CONFIGURE_ARGS =       --with-jpeg-lib=${LOCALBASE}/lib/
                     31:
1.5       yason      32: REGRESS_TARGET =       test
                     33:
                     34: post-configure:
                     35:        @perl -pi -e 's|/bin/bash|${LOCALBASE}/bin/bash|g' \
                     36:                ${WRKSRC}/tests/run-tests.sh
1.2       yason      37:        @perl -pi -e 's|--strip-trailing-cr --brief|-b|g' \
                     38:                ${WRKSRC}/tests/run-tests.sh
                     39:
                     40: post-install:
                     41:        ${INSTALL_DATA_DIR} ${PREFIX}/share/doc/jp2a
1.7     ! yason      42: .for i in AUTHORS COPYING LICENSES
        !            43:        ${INSTALL_DATA} ${WRKSRC}/$i \
        !            44:                ${PREFIX}/share/doc/jp2a/$i
        !            45: .endfor
1.2       yason      46:
1.1       yason      47: .include <bsd.port.mk>

CVSweb