[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / devil

File: [local] / ports / graphics / devil / Attic / Makefile (download)

Revision 1.5, Sun May 30 09:23:16 2010 UTC (14 years ago) by yason
Branch: MAIN
Changes since 1.4: +2 -3 lines

correct WANTLIB and LIB_DEPENDS

# $OpenBSD$

COMMENT =		full featured cross-platform image library

DISTNAME =		DevIL-1.7.8
PKGNAME =		${DISTNAME:L}

SHARED_LIBS +=		IL	0.0 # .2.0
SHARED_LIBS += 		ILU	0.0 # .2.0
SHARED_LIBS += 		ILUT	0.0 # .2.0

CATEGORIES =		graphics

HOMEPAGE =		http://openil.sourceforge.net/

#MAINTAINER =		???

# LGPLv2.1
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

WANTLIB = 		GL GLU ICE SM X11 Xau Xdmcp Xext Xi Xmu Xrandr Xrender \
			Xt Xxf86vm c iconv jpeg m pthread pthread-stubs sndio \
			stdc++ tiff usbhid xcb z

MASTER_SITES =		${MASTER_SITE_SOURCEFORGE:=openil/}
EXTRACT_SUFX = 		.zip

LIB_DEPENDS =		alleg::games/allegro \
			SDL::devel/sdl \
			glut::graphics/glut \
			Half,Iex,IlmThread,Imath::graphics/ilmbase \
			IlmImf::graphics/openexr \
			jasper::graphics/jasper \
			lcms::graphics/lcms

USE_X11 =		Yes
USE_LIBTOOL =		Yes
CONFIGURE_STYLE =	autoconf
AUTOCONF_VERSION = 	2.61
CONFIGURE_ARGS +=	--enable-ILU \
			--enable-ILUT \
			--with-examples \
			${CONFIGURE_SHARED}
CONFIGURE_ENV = 	LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -pthread" \
			CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include/"

NO_REGRESS =		Yes

WRKDIST =		${WRKDIR}/${DISTNAME:L}

post-extract:
.for i in configure build-aux/install-sh
	chmod +x ${WRKSRC}/$i
.endfor

.include <bsd.port.mk>