[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / devil

Annotation of ports/graphics/devil/Makefile, Revision 1.9

1.1       yason       1: # $OpenBSD$
                      2:
                      3: COMMENT =              full featured cross-platform image library
                      4:
                      5: DISTNAME =             DevIL-1.7.8
                      6: PKGNAME =              ${DISTNAME:L}
                      7:
1.4       yason       8: SHARED_LIBS +=         IL      0.0 # .2.0
                      9: SHARED_LIBS +=                 ILU     0.0 # .2.0
                     10: SHARED_LIBS +=                 ILUT    0.0 # .2.0
1.1       yason      11:
                     12: CATEGORIES =           graphics
                     13:
                     14: HOMEPAGE =             http://openil.sourceforge.net/
                     15:
                     16: #MAINTAINER =          ???
                     17:
                     18: # LGPLv2.1
                     19: PERMIT_PACKAGE_CDROM = Yes
                     20: PERMIT_PACKAGE_FTP =   Yes
                     21: PERMIT_DISTFILES_CDROM =Yes
                     22: PERMIT_DISTFILES_FTP = Yes
                     23:
1.7       yason      24: WANTLIB += GL GLU Half ICE Iex IlmImf IlmThread Imath SM SDL X11
                     25: WANTLIB += Xau Xcursor Xdamage Xdmcp Xext Xfixes Xi Xmu Xpm Xrender
                     26: WANTLIB += Xt Xxf86dga Xxf86vm alleg c drm glut iconv jasper jpeg
                     27: WANTLIB += lcms m pthread pthread-stubs sndio stdc++ tiff usbhid xcb z
1.1       yason      28:
                     29: MASTER_SITES =         ${MASTER_SITE_SOURCEFORGE:=openil/}
1.8       yason      30: EXTRACT_SUFX =                 .zip
1.1       yason      31:
1.9     ! yason      32: LIB_DEPENDS =          games/allegro \
        !            33:                        devel/sdl \
        !            34:                        graphics/freeglut \
        !            35:                        graphics/ilmbase \
        !            36:                        graphics/openexr \
        !            37:                        graphics/jasper \
        !            38:                        graphics/lcms
1.1       yason      39:
                     40: USE_LIBTOOL =          Yes
1.4       yason      41: CONFIGURE_STYLE =      autoconf
                     42: AUTOCONF_VERSION =     2.61
1.1       yason      43: CONFIGURE_ARGS +=      --enable-ILU \
                     44:                        --enable-ILUT \
                     45:                        --with-examples \
                     46:                        ${CONFIGURE_SHARED}
1.2       yason      47: CONFIGURE_ENV =        LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -pthread" \
1.1       yason      48:                        CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include/"
                     49:
1.2       yason      50: NO_REGRESS =           Yes
1.1       yason      51:
                     52: WRKDIST =              ${WRKDIR}/${DISTNAME:L}
                     53:
                     54: post-extract:
                     55: .for i in configure build-aux/install-sh
1.2       yason      56:        chmod +x ${WRKSRC}/$i
1.1       yason      57: .endfor
                     58:
                     59: .include <bsd.port.mk>

CVSweb